NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
While debugging, local file mapping fails...


Joined: 09 Dec 2003
Posts: 3
Location: Compiègne, France
Reply with quote
Hi

I've got a mapping problem. When a script is launched on the server, the debugger is launched but cannot find the local file attached to the server script....

So, i have a "Failed to find local file "/var/www/html/claroline/test.php" corresponding to "/var/www/html/claroline/test.php" remote file, althrough the "Remote root directory" parameter is set to "/var/www/html/". the mapping isn't done and phpEd searches for a unix path on my local computer without replacing the begining of the path.

Details beyond:

I've got a linux server (http://claroline, apache, php with php debugger lib) and a phpED trial.

In phpED, I've got an active project with these settings
Root Directory : C:\Program Files\nusphere\phpED\Projects\project2
...
Account: <ftp account pointing to to dvlpt dir : /var/www/html/, at ftp root : "/">
Top publishing directory : "/"
...
Run Mode : HTTP mode (remote web server)
Root URL : http://claroline/
Remote root directory : /var/www/html/


Can anyone help ?
thanks
View user's profileFind all posts by romlelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
sure.
Please tell me how do you run debug session ?

As I understand you'd open
C:\Program Files\nusphere\phpED\Projects\project2\claroline\test.php
and press "Run in debugger" or step-in.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 09 Dec 2003
Posts: 3
Location: Compiègne, France
Reply with quote
no, in fact, I just run the script on a normal browser and the execution is "caught" by the debugger in phpED. The debugging session starts but, in the log, I've got the mapping error message, so, either the debug session halt imediatly (no breakpoints, so execution is fast) or I've got a temporary file (non mapped file) to debug (if in the settings I disable mapping error blabla....)

So, I can debug in the second case, but it is not very user friendly to be obliged to set up breakpoints at each execution. I would prefer the mapping to work Wink

I can send you a screenshot if it can help you.

Thanks a lot for your help
View user's profileFind all posts by romlelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
ok, thanks
I'll have a look.
In case of any problems, we'll fix them in the next release
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 09 Dec 2003
Posts: 3
Location: Compiègne, France
Reply with quote
Here is a sample walkthrough....
have I made a mistake ?

With my project configuration, I excpect the begining of the server path to be replaced by my project local directory....



thanks again
View user's profileFind all posts by romlelSend private message
While debugging, local file mapping fails...
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic