NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
SOLVED: Unable to load dynamic library ...dbg-php-7.1.so
Veteran

Joined: 22 Sep 2005
Posts: 113
Reply with quote
I've setup a vmware virtual system:
Opensuse Leap 42.3 (x86_64)
Apache 2.4.32 compiled from source
PHP 7.1.16 compiled from source
Mysql 5.7.21, Postgresql 10.3, etc all compiled from source

This system run perfectly everything, except that I can't load dbg-php-7.1.so extension.
In php.ini:
extension_dir="/progs/php/include/php/ext"
extension=dbg-php-7.1.so
[debugger]
debugger.JIT_enabled=On
debugger.fail_silently=Off
debugger.hosts_allow=localhost 127.0.0.1 clienthost
debugger.hosts_deny=ALL
debugger.profiler_enabled=On
debugger.ports=7869, 10000/16

This dbg-php-7.1.so was extracted from PhpED's debugger/dbg-8.2.12-Linux.tar.gz > x86_64

On Apache start:
PHP Warning: PHP Startup: Unable to load dynamic library '/progs/php/include/php/ext/dbg-php-7.1.so' - /progs/php/include/php/ext/dbg-php-7.1.so: undefined symbol: compiler_globals in Unknown on line 0

Any hint to solve this?

SOLVED:
I notice that phpinfo shows Zend Extension Build API320160303,TS <<<
Using the x86_64_TS version of the extension, it was loaded.
View user's profileFind all posts by HoTShoTSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
you were trying to load non-TS module with TS php binary
Seems you figured that out yourself

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
SOLVED: Unable to load dynamic library ...dbg-php-7.1.so
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic