NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
NuSphere 18017: Debugger cannot find project for Debugging


Joined: 08 Dec 2008
Posts: 33
Reply with quote
After update, cannot debug project, never hits breakpoints.

I am using a shared directory (\\server\www) with sub directories for my projects.

So, the project I am working with is located on the following: \\server\www\crm, which is a secure site (https:\\crm.server.com).

Walk through debugger properties setup wizard gets to the last step and get an error (not really an error though) stating: Error (-143) executed file from different directory (/var/www/crm/) than expected (/var/www/).

This has always passed the tests in previous releases (been customer for 8 years).

Please help.

Running debugger on Ubuntu 12.04 LTS, PHP 5.3.10, NuSphere 18017 latest debugger deployed
View user's profileFind all posts by radi8Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7835
Reply with quote
you need to run Project settings wizard and make sure all the checks are passed

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Dec 2008
Posts: 33
Reply with quote
Thank you Dimitri, I was able to get this to work. All of these settings have worked for years the way they were and I go confused about them all of a sudden just failing.

I am sure there is a reason for everything though.

Appreciate your help.

Evil or Very Mad
View user's profileFind all posts by radi8Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7835
Reply with quote
I'm sorry for that. There was no intention to introduce any backward incompatible changes.
Do you have more details on what setting(s) needed to change in v18? What was old setting value and what's the new one?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Dec 2008
Posts: 33
Reply with quote
Yes, the Web Document Root setting. Typically, it is set to the root folfer of the server: /var/www. But, to make this work, I had to set it to the project root folder: /var/www/crm.

A simple change, but the instruction specifically state: Dbg-Wizard has determined the web server root (not project) directory. If it is incorrect, please update it in the input below.

To make this work, I had to use the the project directory.
View user's profileFind all posts by radi8Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 7835
Reply with quote
It always needs the project root. It works this way from the beginning.

Quote:
Dbg-Wizard has determined the web server root


Dbg-Wizard is intended to work with Project Settings Wizard. If nevertheless you invoke it directly, it can't guess your project settings and will not validate them.
In your case the project is in the web sub-folder. How would Dbg-Wizard, running in the web root, guess that?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
NuSphere 18017: Debugger cannot find project for Debugging
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic