NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debugging with the use of $HTTP_POST_VARS


Joined: 24 Sep 2003
Posts: 1
Reply with quote
Hi,

I am using Apache with DreamweaverMx/Phakt configuration. The interface is done between page and php by $HTTP_POST_VARS with form variables that have been posted. Such as the hidden field $HTTP_POST_VARS("MM_insert"). When I run the page via the browser these fields are updated and contain the information that I want. When I try phped in a debugging session they are always undefined. Does anyone know how I can fix this?
View user's profileFind all posts by dave_heslopSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
can-t-get-parameters-t119.html
phped-local-web-server-not-parsing-embedded-php-code-in-html-t85.html
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Is php.ini file wrongly pointed-to, or something else wrong


Joined: 20 Oct 2003
Posts: 2
Reply with quote
Hello,

I have just started using PHPEd, and it is quite intuitive to handle. Also the doc is easily browsed, as is the support site. But still, I have a problem that I don't see answered at first sight: my Windows browser browsing a Linux machine (that in turn has MySQL, PHP and Apache) correctly handles the code, using global variables. But PHPEd does not seem to detet that setting. However, I DO have the same php.ini on both environments, and both ARE containing register_globals = On.
In the documentation and the support pages, I see this fenomenon (i.e., a different behaviour between both setups) coming back with 'register_globals' as the cause of all trouble. But in my case, both code bases ARE the same (the one is a link over Samba to my Linux box code, so there's no doubt on that), and BOTH php.ini's ALSO are the same (double checked already several times).
Debugging otherwise works OK (debug dll has been renamed from the proper version), so why could there still be a different behaviour ?
(My setting on Linux : MySQL 4.0.15a, PHP 4.3.3, on Windows : PHPEd 3.2.1)

Thanks for any helpful support,

Kind regards,

Philippe Bertin.
View user's profileFind all posts by fluppSend private message
Was this due to a bug, or did I wrongly use the program ?


Joined: 20 Oct 2003
Posts: 2
Reply with quote
I found the problem, but it was not as intuitive as I expected: seems that when you change the settings (Tools - Settings - Debug tab, php.ini file setting), this setting is NOT taken into account, is it ? Because when I change that setting to have php.ini point to the php.ini of my remote computer's php.ini (in my case : Y:php.ini), and then let PHPEd generate a phpinfo()- file, PHPEd continues to give the php.ini setting of C:/Program Files/...., i.e. the standard setting for PHPEd.

Once I changed the file in C:/Program Files/... to be the same as my remote (Linux server) PC's php.ini (i.e., with 'register-globals' truly set to 'On' this time), everything worked fine.

What is wrong here ? Is this a bug, of just a wrong usage of the program ? Could I eventually have found this in the documentation ?

Kind regards
View user's profileFind all posts by fluppSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
When you open php.ini in PHPED you just open a file for editing. It's not the way for specifying where php should get php.ini from.
If you want to change location of PHP.INI you have to add SYSTEM wide environment variable named PHPRC.
Read php manual for further details.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugging with the use of $HTTP_POST_VARS
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic