NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
dbg-3.8.0 on Fedora 10


Joined: 05 Nov 2007
Posts: 4
Reply with quote
I get the following error:
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php/modules/dbg-php-5.2.so' - /usr/lib/php/modules/dbg-php-5.2.so: cannot enable executable stack as shared object requires: Permission denied in Unknown on line 0

dbg-3.6.11 loads fine. I used the one from glibc-2.7(Linux version) since Fedora 10 is using: glibc-2.9-3.i686

I noticed that you DON'T have a glibc-2.7 with this Linux version, like you did before. Only have glibc-2.3.

Don't know if that is causing the problem.
View user's profileFind all posts by JimWSend private message


Joined: 03 Feb 2009
Posts: 4
Reply with quote
I'm not sure on the exact error but my server administrator has also had problems installing this latest version of dbg, this is on CentOS.
View user's profileFind all posts by phpcrunkSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Quote:
Unable to load dynamic library '/usr/lib/php/modules/dbg-php-5.2.so' - /usr/lib/php/modules/dbg-php-5.2.so: cannot enable executable stack as shared object require


RTFM. The message is selfexplanatory.

If you enabled Linux SE, don't forget to prepare binaries by running
execstack -c /usr/lib/php/modules/dbg-php-5.2.so

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 05 Nov 2007
Posts: 4
Reply with quote
What's different?? Never had to this with any of the previous versions??

Thanks will try it
View user's profileFind all posts by JimWSend private message
dbg-3.8.0 on Fedora 10
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic