NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Can not understand how listener starts


Joined: 31 Jul 2012
Posts: 2
Location: Ramat Gan, Israel
Reply with quote
Hello, folk.

Really searched pretty much but either I'm blind or this topic is not covered enough.

My purpose is to setup remote debugging through SSH tunnel. DBG module loaded well. SSH tunnel also works well (tested with netcat). But no listener on server side listens for localhost:7869 (not my desktop localhost but server's localhost).

So my questions are:
1) who starts this listener? Some event or manually/init-script?
2) where can I obtain one?

Even in manual and in FAQ DBG module mentioned but listener not.
And this thread completely frustrated me. Listener should be on Desktop? So what the SSH tunnel for? Who can explain the workflow?

Appreciate much any help!
****
Server is based on Debian x64_86, no thread safe. PHP 5.3


DBG module ini-settings:

Code:
# cat /etc/php5/conf.d/dbg.ini

; configuration for DBG
extension=dbg-php-5.3.so

[debugger]
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow=localhost, ::1, 127.0.0.1
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16
debugger.JIT_host = clienthost
debugger.JIT_port = 7869


Loaded DBG module running settings:
Code:
# php -i | grep -v 'with DBG' | grep -v 'conf.d/dbg.ini' | grep -i -A 27 dbg
dbg

Version => 4.5.1
Linked => as a shared library.
Dbg SSL => not available
Dbg ip security => enabled.
Profiler => enabled
Target PHP version => 5.3.x
Server API => Command Line Interface
Extensions API => 220090626
Modules API => 20090626
PHP API => 20090626

Directive => Local Value => Master Value
debugger.enable_session_cookie => On => On
debugger.enabled => On => On
debugger.fail_silently => Off => Off
debugger.hosts_allow => <i>protected value</i> => <i>protected value</i>
debugger.hosts_deny => <i>protected value</i> => <i>protected value</i>
debugger.ignore_nops => Off => Off
debugger.IPv6_enabled => On => On
debugger.JIT.enabled => Off => Off
debugger.JIT.host => clienthost => clienthost
debugger.JIT.ignore_exceptions => no value => no value
debugger.JIT.port => 7869 => 7869
debugger.JIT.trig_errors => no value => no value
debugger.JIT.trig_exceptions => Exception => Exception
debugger.net.chunksize => 48000 => 48000
debugger.net.maxpacketsize => 50000000 => 50000000
debugger.ports => <i>protected value</i> => <i>protected value</i>
debugger.profiler_enabled => On => On
debugger.session_nocache => On => On
debugger.timeout_seconds => 300 => 300
View user's profileFind all posts by EspritSend private message


Joined: 31 Jul 2012
Posts: 2
Location: Ramat Gan, Israel
Reply with quote
Damn, got it!
Answer were here:
Quote:
NOTE: If you're using Putty ssh client, don't forget that debugger requires REMOTE (REVERSE) tunnel. LOCAL (DIRECT) tunnels won't work in our case


I mistaken in SSH tunnel direction. I've set desktop's localhost:7869 to be forwarded to server's localhost:7869.
But had to forward server's localhost:7869 to desktop's localhost:7869.

So in Putty(Connection-->SSH-->Tunnels) it should look like: R7869 localhost:7869
View user's profileFind all posts by EspritSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
BTW next version will support tunnels for debugging without any external tools (like putty).

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Oct 2012
Posts: 1
Reply with quote
thanks for all the links. appreciate it.
View user's profileFind all posts by wyllfritscheSend private message
Can not understand how listener starts
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic