NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
TIP: Troubleshooting debugger communications/SSH
Site Admin

Joined: 13 Jul 2003
Posts: 7823
Reply with quote
TIP: Troubleshooting debugger communications/SSH

If you run debug session through SSH connection and it fails to start, please proceed with the following steps and they will help you identify the problem:

1. Make sure you set up debugger and IDE to work though SSH (see instrunctions here)
2. make sure ssh tunnel, phped and dbglistener are running on the client computer.
3. make sure sshd (server host) has opened listening socket. Command below should show 7869 port in listening state:
Code:
netstat -na|grep 7869

4. run telnet on the server and make sure it successfully connects back to the dbglistner:
Code:
telnet localhost 7869

Immediately after you run telnet you'd see black dot inside the white circle in DbgListener icon and something like "01.01.2004 11:11:14 <serverIP> client connected" in the DbgListener log window.
5. Make sure the following lines are in php.ini
Code:
debugger.hosts_allow=localhost
debugger.hosts_deny=ALL
View user's profileFind all posts by dmitriSend private messageVisit poster's website
TIP: Troubleshooting debugger communications/SSH
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic