NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Smart sync [RESOLVED]


Joined: 24 Jun 2019
Posts: 20
Reply with quote
Hm I just began noticing problems with smart sync
Loading is extremly slow. Seems that it hangs at last directory.
This is a problem with any project. Cache is enabled, compression is set to off, and number of files/directories is under 500
View user's profileFind all posts by dp41646Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
- Is your project configured to use ssh / sftp account?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Jun 2019
Posts: 20
Reply with quote
Yes, I am using sftp
View user's profileFind all posts by dp41646Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
Can you configure it to work without ssh/sftp account?
I mean to test if it helps. That would exclude ssh/sftp from consideration

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Jun 2019
Posts: 20
Reply with quote
Hi Dmitri,

yes, FTP works like a charm.
EDIT: and yes, I can't explore any of SFTP account in explorer tab, but FTP works normally.
Do I have to reset some SSH config or something like that, after latest upgrade?
View user's profileFind all posts by dp41646Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
I checked smart sync -> select all, download in 19.2 and 19.3 against public ssh server. Worked with the same performance (19.3 was ~1sec faster). Public-key authentication, didn't use ed25519 neither keys nor key-exchange.

I doubt it would help but we can try to isolate the problem by turning off what was added in ssh client in 19.3:
Find the account in tools->Accounts, then check the name in "SSH settings" line, then find this name on Keys tab under "SSH settings" folder, then turn off the following 3 checkboxes:
Deffie-Hellman group 16 sha512, Deffie-Hellman group 18 sha512 and Deffie-Hellman over Curve25519 sha256.

Then run `ssh -Q key` on your server. It will print ssh key algorithms supported by your server. If you see 25519, turn this algorithm off
by adding `HostKeyAlgorithms -ssh-ed25519` in sshd seetings and restart sshd service.

Alternatively, if you can find a host with an old sshd, a version prior to 6.5 -- it's when support for ed25519 was introduced, give it a try.

Finally, check the version that worked fine for you. Let me know if it was shipped with ssleay32-1.0.2t.dll or an earlier version. Perhaps, this is the most important thing to check now. Perhaps it's the same.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Jun 2019
Posts: 20
Reply with quote
Hi Dmitri,

Thx. I will try that.
I ve upgraded phped even on other laptop I have, and have same problem with sftp there, too.
View user's profileFind all posts by dp41646Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
Check if you have %APPDATA%\NuSphere\PhpED-1920 directory. If you do, it's where 19.2 settings are saved. It means that you can install 19.2 into a non-default directory (like %PROGRAMFILES%\NuSphere\PhpED-19.2) and you'll be able to compare. Just don't run them concurrently with the same active project.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Jun 2019
Posts: 20
Reply with quote
Ok
I tried uncheck 3 algos, and on all my servers 25519 is supported.
I've turned this algorithm off, restarted, but nothing changed - I still can't access sftp.
Smart sync is maybe misleading, because on the first I didn't noticed that I can't even explore files by SFTP protocol.

I've reverted back to 19.2 (clean install), and everything is fine - SFTP is working again.

I doubt that this is some server issue, because I've tried to connect to 3 different servers (all of them are centos/whm, with latest updates).
View user's profileFind all posts by dp41646Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
Well, this problem is due to bug in compiler when optimization is on and target platform is 64bit.
Hope a workaround or fix will be implemented shortly.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Smart sync [RESOLVED]
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic