NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
"Sha-Bang" output in CLI mode


Joined: 30 Jan 2007
Posts: 35
Reply with quote
I'm not sure if this is a bug, or a bad setting, but is there a setting so that phpExpress does not output the "Sha-Bang" part of a CLI script?

For example, we use quite a few PHP command-line scripts on the same server as our website.

To save typing "php scriptname.php" all the time, we just put:
Code:
#! /usr/bin/php -q

at the top of the scripts and then make them executable.

This has worked for years, however, with the latest addition of configuring PhpExpress on the server, that line at the top of the file is considered as output by PHPExpress.

If I disable the extension, there is no output (as expected)
[I'm using PHPExpress for PHP5.2 on Linux x86 32-bit for glibc2.3]

Replicating the issue:

Create a script as simple as:
Code:
#! /usr/bin/php -q
<?php
print "Hello World!\n";


Expected output:
Code:
Hello World!


Actual output:
Code:
#! /usr/bin/php -q
Hello World!


If you disable the "extension=phpexpress-php-5.2.so" from php.ini, the output is as expected.
View user's profileFind all posts by rgagnonSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7835
Reply with quote
phpexpress-3.0.1(build 3025) works like you expected

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
"Sha-Bang" output in CLI mode
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic