NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[Fixed] Problems with Horde webmail


Joined: 16 Oct 2006
Posts: 29
Reply with quote
When the extension phpexpress-php-4.3.so is set in php.ini, this problem appears in the webmail:

Required "Array" not specified in DataTree SQL configuration. The file /config/conf.php should contain a $ conf['storage']['params']['Array'] setting.
View user's profileFind all posts by MiguelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
Did you install phpexpress 1.3.11 or an earlier version? In latter case, please update to 1.3.11 (it's on the site since yesterday).

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 16 Oct 2006
Posts: 29
Reply with quote
How to update ??? simply uninstall old version and install new version ? If yes, will not be easier to provide that as a ZIP ?


Last edited by Miguel on Wed Jan 03, 2007 4:26 pm; edited 1 time in total
View user's profileFind all posts by MiguelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
just replace module, restart web and check phpinfo to make sure new version is there Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 16 Oct 2006
Posts: 29
Reply with quote
Ah ok ... so i don't need to re-encode the files ... right ? just the web module that changes ...
View user's profileFind all posts by MiguelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
Although PhpExpress supports any files encoded with Nu-Coder and previously encoded files will load, the encoder itself may change from version to version and produce more (or less) correct bytecodes. I'd recommend you to re-encode the project and check.
BTW, what's the reason to encode an open-source project?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 16 Oct 2006
Posts: 29
Reply with quote
I don't want to encode horde webmail ... the installation of this extension make a side effect with horde ...
View user's profileFind all posts by MiguelSend private message


Joined: 16 Oct 2006
Posts: 29
Reply with quote
By the way, version 1.3.11 did not fix that problem ...
View user's profileFind all posts by MiguelSend private message


Joined: 16 Oct 2006
Posts: 29
Reply with quote
Can someone that have Horde webmail install on is server and the phpexpress extension install in php.ini tell sme if the webmail works ?
View user's profileFind all posts by MiguelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
I tried SquirrelMail and it worked well.
I'll check what's up with Horde in a week or less.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 16 Oct 2006
Posts: 29
Reply with quote
something new ?
View user's profileFind all posts by MiguelSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
The problem is replicated. Fix will be available by the end of this week.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[Fixed] Problems with Horde webmail
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic