NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
problem with JavaScript win


Joined: 23 Nov 2006
Posts: 3
Location: Munich, Germany
Reply with quote
Hello,

I have a web-app (php 5.1, ionCube loader) which runs fine on my apache linux server from IE or Firefox.
It also runs fine on phpDock ... except for:

A help function in the app calls a JS func which opens a particular php file in a separate window (help screen).
On a standalone WinXP machine the phpDock version won't display the passed php file (it shows the startup screen).
(Otherwise it works fine.)
If I now start a "normal" IE session and browse to localhost:8001 (which surprised me in that this worked at all!)
the JS popups work fine. Indeed, now that IE "proper" is running so does the same functionality in the parallel phpDock version.
Stopping and starting the IE session turns the phpDock apps' ability to display the correct page off and on.

Having narrowed the problem down this far I'm at something of a loss to know what else I could do. Any ideas?

Thanks,

Andrew Murray
View user's profileFind all posts by amurraySend private message
Further information


Joined: 23 Nov 2006
Posts: 3
Location: Munich, Germany
Reply with quote
Hello again,

a similar problem occurs with PhpDock and JavaScript clipboard copying. The PhpDock/IE doesn't seem to support the JS clipboard functionality. A separate "real" IE being served from the PhpDock server works okay.

There's something different about PhpDock's IE client's JS handling.

Any ideas?
View user's profileFind all posts by amurraySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7826
Reply with quote
what URL do you use for the window? Are you aware of current URL (document location) the script is running on?
Just put alert with URL location you're trying to open Smile
Most probably URL is wrong and therefore won't open.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Problem with Javascript and new windows


Joined: 23 Nov 2006
Posts: 3
Location: Munich, Germany
Reply with quote
Well, yes, I did check the path .... and a little more attention to the specific problem I documented above would have been appreciated. As I said, the problem is with PhpDock and does not appear with LAMP nor local IE client.

With some testing I have found that the problem is actually with losing the session data after a javascript window call.

Both this issue and the failing of clipboard functionality have been recently reported by others here.

I would think that that should be sufficient to prompt a more detailed analysis?
View user's profileFind all posts by amurraySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7826
Reply with quote
A screenshot with alert that shows URL or sources that will replicate the problem would be enough to show where there problem is and would help us find a solution.

Quote:
With some testing I have found that the problem is actually with losing the session data

There is no problems with session data in PhpDock. PhpDock does not support sessions, php does. So you need to adjust settings in php.ini if sessions do not work for you. By default sessions are not auto-started so you have to start them explicitly. Read php manual for further details. There is nothing PhpDock might affect.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 16 Dec 2014
Posts: 1
Reply with quote
With some testing I have found that the problem is actually with losing the session data after a javascript window call.




_________________________________
View user's profileFind all posts by hazelmikeSend private message
problem with JavaScript win
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic