NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
phpED FTP connecting without directory listing


Joined: 12 Aug 2009
Posts: 3
Reply with quote
Hello,

I have a new project that uses IIS. phpED's ftp works will as long as I am connecting to a Linux server. When connecting to IIS I get a connection however I do not get a directory listing. I can create new directories... but they do not show in a listing. However, everything appears and lists well when I use an alternate FTP client. This leads me to believe my permissions are correct. I only have display issues when connecting with phpED.

Any thoughts?
Question
View user's profileFind all posts by jlandersSend private message
Guru master

Joined: 24 Jul 2009
Posts: 710
Reply with quote
Try switching the FTP connection in PhpED between Passive and Active modes. Often when you don't see any files listed you just need to switch that mode.

For Linux sites I normally use Passive but on some Microsoft FTP sites the Active setting works. Microsoft FTP does actually support both modes but it is often firewalls either on client or server that get in the way of things.
View user's profileFind all posts by plugnplaySend private message


Joined: 29 Feb 2012
Posts: 6
Reply with quote
Hi,

I found this also - all my files that I uploaded actually went into the "Default FTP Site" folder - all of my other ftp clients connected successfully except phpEd. To fix this I stopped using IIS FTP Server and installed FileZilla Server on the IIS box which worked fine. Pain in the *** but it was the only way I could do it.

Kind Regards - Trev
View user's profileFind all posts by scrivvysolutionsSend private message
Guru master

Joined: 24 Jul 2009
Posts: 710
Reply with quote
I exclusively use Linux with PHP, except on my development server. So I don't normally FTP to Windows servers from PhpED. However, I just tested it to Microsoft FTP on a Windows 2008 server (which still uses IIS 6 for the FTP side of things) and it worked perfectly in both Active and Passive modes. I know this server supports both modes because I specifically configured the server firewall to support both.

Whilst I realise that scrivvysolutions had their files go into Default FTP Site, without there being some sort of issue with either the configuration or security on that server, I don't understand how PhpED could be responsible for that.

If PhpED is supplying the correct username/password, then the server is responsible for setting the initial working directory. If PhpED sets an incorrect working directory then the server appears to be letting it do that. And if PhpED is not supplying logon information, then the server appears to be providing anonymous access.

There have been a few issues with FTP in PhpED, and FTP in general is full of issues between different servers anyway. A lot of FTP clients have special code to handle differences between various servers. But I get the nagging feeling that something isn't correct on the server side.

Have you set the root directory in the PhpED settings for that FTP account?

As for seeing blank folders, that is still a common symptom of incorrect mode, although often accompanied by an error of some sort.
View user's profileFind all posts by plugnplaySend private message
phpED FTP connecting without directory listing
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic