NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
permissions question


Joined: 19 Aug 2006
Posts: 76
Reply with quote
I work on a webapp with a friend. I try to setup permissions on the server (Centos 4) in a way that we can both work on the same files, without permissions problems.

Let's say the project root is /project.

1. I created a group "thegroup" and added my friend and I to it.
2. I changed permissions so that every files and folders created in the project would belong to thegroup:
- chgrp -R thegroup /project
- chmod -R g+s /project
3. I changed my umask to 002 so that so that every files and folders I created in the project would be readable and writable by the group. I added "umask 002" to my .bash_profile.
4. In phpEd, I set "Default permissions for folders" to 775 and "Default permissions for files" to 664

But if I upload a file from phpEd, its permission are 644, not 664, the file is not writable for my friend!

What am I missing?

Thanks!

JL
View user's profileFind all posts by jlSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
I think that what you set in .bash_profile has no effect because sftp does not use bash for file operations. At least it's completely up to your sshd daemon Smile and does not depend on the IDE.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 19 Aug 2006
Posts: 76
Reply with quote
Yes you right! But the problem is still not solved! Smile

Anyway, I installed Subversion and work through it with my friend now instead of working directly with the files. Works great.
View user's profileFind all posts by jlSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
working directly with your friend on the same set of files, sooner or later you will override each other's files, so it seems that using source control is the only way Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
@jl In my experience the permission setting work fine when using SFTP, but not with FTP. Change your connection to SFTP (you may need shell access for this to work) and see if that solves your problem.

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 19 Aug 2006
Posts: 76
Reply with quote
I was using SFTP, but thanks anyway.
View user's profileFind all posts by jlSend private message
it seems this bug is still present in build 5976


Joined: 08 Oct 2006
Posts: 18
Reply with quote
putting Default permissions for SFTP to 0775 or 775 or 0664 or 664 will always put them as 775 no matter what.
This is proving quite problematic for me.
Is there a plan on having this fixed anytime soon?
View user's profileFind all posts by bryxalSend private message
Veteran

Joined: 06 Jun 2007
Posts: 289
Location: Vancouver, Canada
Reply with quote
The permission settings are working fine for me. I am using build 5966 (I am a couple behind).

_________________
Smile
View user's profileFind all posts by annoSend private messageVisit poster's website


Joined: 16 Nov 2010
Posts: 2
Reply with quote
working directly with your friend on the same set of files,
sooner or later you will override each other's files,
so it seems that using source control is the only way
Thanks,,,


View user's profileFind all posts by Sugar70Send private messageYahoo Messenger
permissions question
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic