NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Material icons error in PhpED 19.5 using embedded chrome


Joined: 31 Jan 2017
Posts: 8
Reply with quote
Loading material icons dosnt work when running PhpED 19.5 and using embedded Chrome browser.

Try the following html - runs OK in Chrome (not embedded).

Code:

<!DOCTYPE html>
<html lang="en">
 <head>
  <link rel="stylesheet" href="https://fonts.googleapis.com/icon?family=Material+Icons">
 </head>
 <body>
  <span class="material-icons">search</span>
 </body>
</html>
View user's profileFind all posts by terje_bakkenSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8203
Reply with quote
Correct name for embedded browser is Chromium. It's not exactly the same as chrome. If something does not work in embedded, you have external Chrome option.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Jan 2017
Posts: 8
Reply with quote
This bug was introduced in version 19.5.
I hope you can fix it.
View user's profileFind all posts by terje_bakkenSend private message


Joined: 31 Jan 2017
Posts: 8
Reply with quote
Embedded Mozilla runs OK!
View user's profileFind all posts by terje_bakkenSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8203
Reply with quote
what's last version you think was working before 19.5?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Jan 2017
Posts: 8
Reply with quote
My previous version was 19.1
View user's profileFind all posts by terje_bakkenSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8203
Reply with quote
in 19.1 it produces the same output in embedded Chromium as in 19.5 -- no material icon


_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Jan 2017
Posts: 8
Reply with quote
Then something else must have changed.
The problem occurs when Chromium is trying to load the font file "https://fonts.gstatic.com/s/materialicons/v92/flUhRq6tzZclQEJ-Vdg-IuiaDsNc.woff2"

[img]https://drive.google.com/file/d/1d7yfptvplfLzIz00A3sIwLmrwzwQ154v/view?usp=sharing[/img]

After trying "Self Hosting" of Material icons version 3.0.2, I get this result:

[img]https://drive.google.com/file/d/1vUrii030k_kK40unqd-IyelsDIXFUCWN/view?usp=sharing[/img]

I'm happy with this and are going to run like this until the problem might be solved.
View user's profileFind all posts by terje_bakkenSend private message
Material icons error in PhpED 19.5 using embedded chrome
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic