NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Lost IDE access to HTML Validator


Joined: 29 Mar 2018
Posts: 37
Reply with quote
Hi,
I decided to update and upgrade my copy of HTML Validator and have now lost all visible access to it from within PhpED.

I updated the link in preferences to point to HTML Validator but now it no longer appears in my menu or as a toolbar button.

I think it might be due to the fact that as I have an upgraded, licenced version rather than the included lite version I am saying NO during installation / upgrade of PhpED as I do not want my full version over written by the included lite version.

Can anyone please advise me how to get the link and toolbar button back?

Thanks and kind regards,

jB Cool
View user's profileFind all posts by britescSend private message


Joined: 18 Mar 2019
Posts: 9
Location: Canada
Reply with quote
JB, I was about to do the same. We have asked the same on the "features request" forum about the outdated HTML Validator and what it can be done. The author of HTML Validator suggested getting the full version instead. However, the question was left open if this will work. Nobody answered it.

I guess you did the test that this doesn't work and we are stuck with the outdated version even if we want to pay the upgrade. Sad
View user's profileFind all posts by carloshSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
Quote:
the question was left open if this will work


Of course, it will, or you'll get full refund
[/quote]

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 18 Mar 2019
Posts: 9
Location: Canada
Reply with quote
@dmitri
So this is a confirmation that if we get CSS HTML Validator 19 from Albert, PhpEd should be able to use it.

I have been waiting for somebody to confirm that this works and most important if this solves the syntax warnings.
View user's profileFind all posts by carloshSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
I don't have this version to try myself, but I have Albert's word that he's maintaining backward compatible API. So it's expected to work fine.
Let me know if there are any problems.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Mar 2018
Posts: 37
Reply with quote
This debate about whether the mechanics of the program work or not are not what my original question was.

I no longer have a menu link or a toolbar button to invoke HTML Validator.
PLease can someone tell me how to get them back?
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
All validators / parsers, including CSE, are working in background. The results are visible in View->Tabs->Problems.
Just make sure that path to CSE is set in Tools->Settings->External Tools.

There are also additional CSE Validator features visible in Workspace->popup for html files and on their file tab popup too. See how they are configured in Tools->Settings->Integration.
If you don't see them on this settings page, try to click Reset

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Mar 2018
Posts: 37
Reply with quote
Thanks.
Recovered to what I want anyway.
But a big please could you allow tools to have their own icon on a tools toolbar.
Please.........

regards,
jB Cool
View user's profileFind all posts by britescSend private message
Lost IDE access to HTML Validator
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic