NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
How to install other specific versions of PHP


Joined: 09 Nov 2021
Posts: 7
Reply with quote
Hi,

My current PhpED 19.5 has the capability to switch between PHP versions 5.4, 5.6, 7.4, 8.0.

I need to install other versions, for testing purposes and while I understand how to configure PhpED to the various versions I have in the X:\Program Files\NuSphere\PhpED folder, I just need to add some more PHP folders in there with all the other specific versions I need to test with.

Can someone please explain what is the best way to create these PHP folders? I have downloaded the specific PHP archives from PHP.net, but the folder content does not match what I have in the PhpED folder.

Thanks,
Adri
View user's profileFind all posts by adricistSend private message


Joined: 30 May 2006
Posts: 79
Reply with quote
Hi,

I use Wamp Server to create switchable environment.
It allows switching not only PHP versions, but also apache servers and databases (mySQL / MariaDB).
Moreover, it has various (powershell) scripts to detect and/or fix various issues, supports virtual aliases, adminer / phpMyAdmin etc.
View user's profileFind all posts by lubosdzSend private message


Joined: 09 Nov 2021
Posts: 7
Reply with quote
Thank you lubosdz,

I can see that the version I am after is part of the v19.0 later installer. I have asked NuSphere for a copy of that installer and if I get it I can then install in a separate folder and just grab and move across the PHP version I need.

Personally I feel that NuSphere should just leave the old trial versions of the latest version installers available to every registered users, this way we can always access and install older PHP versions if we need to.

Failing that, I might go the Wamp Server route.

Thank you for your feedback, it is appreciated and I will look more into Wamp Server later on for those other aspects you have mentioned.

Regards,
Adri
View user's profileFind all posts by adricistSend private message
How to install other specific versions of PHP
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic