NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debug Installed Wizard Fails with PHP 8


Joined: 29 Mar 2018
Posts: 46
Reply with quote
Hi,
PhpEd x64 19515
Just installed above version to gain access to PHP 8.
When running I get the Error that there is a mismatch with PHP.
First time said project PHP was (BLANK) , installed was 8.0.7.
Shall I try and fix? So I said yes and reran wizard.
This time it says project is using 7 but 8.0.7 is installed etc.

Any ideas please?

Tried to upload image by it fails.

Thanks and kind regards,

jB Cool
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8201
Reply with quote
19515 is not the latest, you may want to update to 19517 or 19518. Stay tuned.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Mar 2018
Posts: 46
Reply with quote
Thanks. It worked on 19518.
I can run through the wizard as far as getting it to check the debugger, then it fails.
"Error (-134) Debug Session did not start. (Debug error =-16)

Setup.
Windows 10 IIS Express
PHP 8.0.7
phpinfo.php runs perfectly so IIS / PHP config assumed to be OK.
ESET and Defender turned off.
dbg-php-8.0.dll added to extensions folder by wizard.
extension_dir = "C:\Program Files\NuSphere\PhpED\php80\extensions"
zend_extension="C:\Program Files\NuSphere\PhpED\php80\extensions\dbg-php-8.0.dll"
[debugger]
debugger.enabled=On
debugger.profiler_enabled=On
debugger.hosts_allow=ALL ; Only allow all during config
;debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16

If anyone has any ideas as normally this doesn't happen to me, it would be much appreciated.

Kind regards,

jB Cool
View user's profileFind all posts by britescSend private message


Joined: 29 Mar 2018
Posts: 46
Reply with quote
Got some more info from looking at dbg-wizard-php

1. Perhaps, DBG Wizard is outdated, please download the latest one from this link
2. Unrecognized/unsuppoted Run-Time (API20200930,TS,VS16), Php version 8.0.7 is not supported by this product. Please check for the product updates at https://shop.nusphere.com/

PhP 8.0.7 is the version supplied with PhpEd???

jB Cool
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8201
Reply with quote
Quote:
"Error (-134) Debug Session did not start. (Debug error =-16)

you may want to read this:
http://forum.nusphere.com/debugger-error-16-timeout-t10785.html

As of the Wizard, you're not update it from the web site -- it would do that on its own (unless you block it).
If you update it manually, check DbgWizard version before you using it. The most recent in 99% cases come with the product in %APPDATA%\NuSphere\PhpED\dbgwizard\ directory.
Current version is
define('DBG_WIZARD_VERSION', '4.2.4201');
Previous version has no clue about PHP8 and will report it's not supported, of course.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Mar 2018
Posts: 46
Reply with quote
Hi,
If I delete the debug dll the wizard inserts it, I recheck the PHP code and restart the IIS server.
It still fails.
None of the buttons on the debug toolbar become active.

If I manually put the dll from the NTS folder into the extensions folder and restart IIS, the icons on the debug bar become active, but the system fails as it is the wrong dll.

Getting a bit confused now. I believe I have followed all the examples implicitly yet debug will not work.
Can you offer me some more advice please?

Thank you.

jB Cool
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8201
Reply with quote
toolbar? what toolbar?
dll? what dll?

Previously you posted that you got right up to "Error (-134) Debug Session did not start. (Debug error =-16)"
It means that correct DLL is installed on the server and it's loaded.
In order to resolve error -16, you can try to set timeout to ~30secs in php.ini
http://forum.nusphere.com/debugger-error-16-timeout-t10785.html

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Mar 2018
Posts: 46
Reply with quote
Hi,

Image upload fails, but I've got snaps of every stage. Can I snd yo a zip with them?

Latest PHP Debugger Config in php.ini
The DLL zend_extension="C:\Program Files\NuSphere\PhpED\php80\extensions\dbg-php-8.0.dll"

Code:
[debugger]
;debugger.hosts_allow=127.0.0.1, localhost, ::1
;debugger.hosts_deny=ALL
debugger.ports=7869
debugger.connect_timeout_seconds=300
debugger.enabled=On
debugger.hosts_allow=ALL
debugger.hosts_deny=
debugger.fail_silently=Off
debugger.IPv6_enabled=On
debugger.JIT.enabled=Off


http://localhost/dbg-wizard.php
Code:
Thank you for using NuSphere DBG Wizard (v4.2.4201). I am your DBG (PHP Debugger) Helper Script.
I will try to help you with setting up your PhpED project and installing DBG - NuSphere PHP Debugger. I'll do my best and suggest the ways to configure things, but if you still having problems, please don't forget: NuSphere's team is committed to making you successful. Here is the list of resources you can use:

DBG debugger installation on the server
Overview of DBG debugger and Project Mappings
NuSphere Forums
and you can always ask us a question using NuSphere Contact Us Form
What did I find out about your system
I assume that you placed me in the root directory of your web server and on your PhpED machine pointed your browser to me - like this: <URL of your web site>/dbg-wizard.php

I see that:

PHP Version:  8.0.7
Web Server:  Microsoft-IIS/10.0
Server Name:  localhost
Platform:  WINNT/x86_64_VS16
Your Client IP Address:  ::1
Your Server IP Address:  127.0.0.1
Port:  80
Your Web Server is on the same machine with PhpED 
Path to website files:  c:\inetpub\wwwroot\
Document Root is:  c:\inetpub\wwwroot\
Your PHP.INI file is:  C:\Program Files\php\php.ini
PHP extensions directory is:  C:\Program Files\NuSphere\PhpED\php80\extensions
DBG (PHP DEBUGGER) Version 10.0.5 is   INSTALLED
How to setup your PhpED Project Properties
I can suggest the following settings for your Project to debug PHP scripts on Server localhost :
You can create new Project by selecting File->New Project or by selecting New Project in the Workspace Pop up Menu
In the Project Properties Dialog set:

Project -> Root Directory:  c:\inetpub\wwwroot\
Mapping -> Run Mode:  HTTP Mode (3-rd party WEB server)
Mapping -> Remote URL:  http://localhost/
Mapping -> Remote Root Directory:  c:\inetpub\wwwroot\ (same as Project -> Root Directory)


http://localhost/phpinfo.php?DBGSESSID=443804721569200001;d=1,p=0,c=1
Code:
DBG 10.0.5

Failed to start DBG session


Reason: debugger read/write timeout
Not sure what it means? Visit http://www.nusphere.com/dbg/?err=-16 for troubleshooting.
If you didn't intend to run debug session you may want to drop debugger cookie by clicking this button:

Debugger request:   "443804721569200001;d=1,p=0,c=1"
Request found in:   "query_string"
Target PHP version: "8.0.x"
Server API:         "CGI/FastCGI"
Extensions API:     "420200930"
Modules API:        "20200930"
PHP API:            "20200930"


As you can see I still cannot run the debugger.
Appreciate any furter support.
Kind reagrds,

jB Cool
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8201
Reply with quote
ok, you have debugger.connect_timeout_seconds=300 in your php.ini, can you check phpinfo() to make sure the setting is in effect?

Quote:
Image upload fails, but I've got snaps of every stage. Can I snd yo a zip with them?
Quote:


you can file ticket to our support if you want to, then reply with images attached

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 29 Mar 2018
Posts: 46
Reply with quote
If I try with the first URI of 127.0.0.1 I get the following

http://127.0.0.1/phpinfo.php

Code:
dbg
DBG   DBG php debugger, version 10.0.5, Copyright 2001, 2021 Dmitri Dmitrienko, http://www.nusphere.com/dbg

Version   10.0.5
Linked   as a shared library.
Dbg SSL   not available
Dbg ip security   enabled.
Profiler   enabled
Target PHP version   8.0.x
Server API   CGI/FastCGI
Extensions API   420200930
Modules API   20200930
PHP API   20200930
Directive   Local Value   Master Value
debugger.ccov_enabled   On   On
debugger.connect_retries   3   3
debugger.connect_timeout_seconds   300   300
debugger.enable_session_cookie   On   On
debugger.enabled   On   On
debugger.fail_silently   Off   Off
debugger.hosts_allow   protected value   protected value
debugger.hosts_deny   protected value   protected value
debugger.ignore_nops   Off   Off
debugger.IPv6_enabled   On   On
debugger.JIT.enabled   Off   Off
debugger.JIT.host   clienthost   clienthost
debugger.JIT.ignore_exceptions   no value   no value
debugger.JIT.port   7869   7869
debugger.JIT.trig_errors   no value   no value
debugger.JIT.trig_exceptions   Exception   Exception
debugger.net.chunksize   131072   131072
debugger.net.maxpacketsize   52428800   52428800
debugger.ports   protected value   protected value
debugger.profiler_enabled   On   On
debugger.session_nocache   On   On
debugger.timeout_seconds   300   300


If I try with localhost, I now get the following.

http://localhost/phpinfo.php

Code:
HTTP Error 500.0 - Internal Server Error
C:\Program Files\php\php-cgi.exe - The FastCGI process exceeded configured activity timeout

Most likely causes:
IIS received the request; however, an internal error occurred during the processing of the request. The root cause of this error depends on which module handles the request and what was happening in the worker process when this error occurred.
IIS was not able to access the web.config file for the Web site or application. This can occur if the NTFS permissions are set incorrectly.
IIS was not able to process configuration for the Web site or application.
The authenticated user does not have permission to use this DLL.
The request is mapped to a managed handler but the .NET Extensibility Feature is not installed.

Things you can try:
Ensure that the NTFS permissions for the web.config file are correct and allow access to the Web server's machine account.
Check the event logs to see if any additional information was logged.
Verify the permissions for the DLL.
Install the .NET Extensibility feature if the request is mapped to a managed handler.
Create a tracing rule to track failed requests for this HTTP status code. For more information about creating a tracing rule for failed requests, click here.

Detailed Error Information:
Module      FastCgiModule
Notification      ExecuteRequestHandler
Handler      FastCGI
Error Code      0x80070102
Requested URL      http://localhost:80/phpinfo.php
Physical Path      C:\inetpub\wwwroot\phpinfo.php
Logon Method      Anonymous
Logon User      Anonymous

More Information:
This error means that there was a problem while processing the request. The request was received by the Web server, but during processing a fatal error occurred, causing the 500 error.
View more information ยป

Microsoft Knowledge Base Articles:

294807
View user's profileFind all posts by britescSend private message
Removed IIS


Joined: 29 Mar 2018
Posts: 46
Reply with quote
The only way that I could get the system to work was to revert to using Apache 2.4 for Windows.
I removed IIS completely.
Now able to continue to work.

regards,
jB Cool
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8201
Reply with quote
Quote:
"Error (-134) Debug Session did not start. (Debug error =-16)


issue is resolved in 19521

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debug Installed Wizard Fails with PHP 8
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic