NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
CSS class autocomplete seems broken


Joined: 09 Feb 2010
Posts: 2
Reply with quote
Hi!

I m using PhpEd v 6.2 build 6236

Now i find that auto complete doesn't work, unless i include the file directly. In past PhpEd would simply scan all the files inside project scope and present list of auto complete options. but now it doesn't work anymore.

It's seriously slowing me down, I got dependent on this feature very much to speed up things.

Any help/suggestion regarding this issue will be very much appreciated Smile

Thanks,
Anjan
View user's profileFind all posts by anjan011Send private messageYahoo Messenger


Joined: 07 Mar 2012
Posts: 14
Reply with quote
Have the same problem (same build), but only for HTML class & ID attributes. PHP functions work fine. Rebuilding indexes as suggested did not help. After cold boot it worked shortly, but then failed again. Opening a style sheet concurrently activates insight/completion, but only for the styles in that particular file which has not have to have any relation with the particular project or file.

_________________
JH
View user's profileFind all posts by jayaitchSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Looks like you turned "Limit Scope To Included" option in the Code Insight settings.
This is what it is intended for and it's off by default btw.
I mean, don't touch default settings until you understand what you're doing Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 Mar 2012
Posts: 14
Reply with quote
That's probably true for the OP.

However, that option is on the PHP pane of Code Insight Settings, and has no effect whatsoever on HTML or CSS.

As it is Code Insight for HTML class/ID presently only works with classes from stylesheets *opened* in the editor. *Any* stylesheet opened in the editor, even if totally unrelated to any of the projects in current workspace. IIRC it worked correctly in 6.1, build 6109.

_________________
JH
View user's profileFind all posts by jayaitchSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
It scans for CSS parts in all files in currently active project.
Make sure that file containing expected class/ID is in the project and this project is active.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 Mar 2012
Posts: 14
Reply with quote
The file is in the project, *.css files are in the project, the project is active.

*.css file linked in header template, header template included per <?php include 'includes/header_e.inc'; ?> in file.

As said PHP functions from library included via header.inc show fine, it's only CSS classes/IDs which don't.

_________________
JH
View user's profileFind all posts by jayaitchSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
If nothing helps, report to the support team.
For me the classes defined in a CSS file appear fine in code completion:

See screenshots:





_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 07 Mar 2012
Posts: 14
Reply with quote
Did you close noname1.css (and any other *.css file) before the test?

_________________
JH
View user's profileFind all posts by jayaitchSend private message
CSS class autocomplete seems broken
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic