NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Can't connect to mySql while debugging... *solved*


Joined: 22 Oct 2004
Posts: 1
Reply with quote
Just as a precursor, I have read FAQ and done a search and have found no info to help me just yet.

The issue is exactly what the subject says - while debugging, the @mysql_connect function in the code consistently returns false, but I CAN connect using the same connection parameters via Navicat (mysql gui admin app) and mysql command line.

I can't connect however creating a connection on the db tab in the IDE - when I attempt to connect, I receive error 1251 - "client doesn't support authentication protocol requested by server; consider upgrading mysql client"

mysql version being used is 4.16
PHPEd version 3.3.3 build 3391

Any help would be greatly appreciated while I evaluate to purchase

thanks in advance
View user's profileFind all posts by qsilverSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
PHPEd is shipped with libmySQL.dll of 3.23 version and it can work with mysql 3.23.x and 4.0.x, for 4.1 you have to install libmySQL.dll from this server. This version can't be distributed with phped because of mysql licensing.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
MySQL 4.1 and PHPEd


Joined: 13 Nov 2004
Posts: 12
Reply with quote
ddmitrie
Is there a way to obtain libsql.dll for mysql version 4.1? or do I have to install version 4.0 of mysql?
Thanks
JS
View user's profileFind all posts by JSSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
I think you should contact mysql AB to obtain their client tools suite which includes the library. We do not distribute it due to the license which bans distributing the library with commercial software that phped is.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 10 Jan 2005
Posts: 9
Reply with quote
BTW, for anyone still struggling with this problem...you're not alone. I am running PhpEd v. 4.0.1 and I separately copied the new MySQL libmysql.dll into the PhpEd directory from the 4.1.18 version of the Windows installation zip file.

It's still not working (same error message as before). I shut down and restarted PhpEd.

Any ideas anyone?

Thanks,

-David V.
View user's profileFind all posts by david102299Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
Dear David,
could you please read FAQ please first?
faq-i-can-t-connect-to-mysql-4-x-from-my-script-t1315.html

you have to update your php, not library in phped's directory.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHPEd 4.5 and MySQL 5.0


Joined: 21 Mar 2006
Posts: 2
Reply with quote
I like just about everything else about PHPEd, but this is driving me crazy...

I have PHPEd 4.5 and MySQL 5.0 installed. I do not have any specific server (Apache, IIS, etc) or PHP version installed. I am running a short

mySQL_connect("localhost","root","(password)")

script through PHPEd and still get the "Client does not support authentication protocol" error.

When I try to open the localhost through the DB window, it opens, no error.

I've downloaded the latest libmysql.dll and php_mysql.dll from the MySQL web site and replaced every single copy of both of those files in both my nusphere and MySQL directories with the versions downloaded from MySQL and still get the error.

The php_mysql.dll is version 5.1.2.2 and is 49,152 bytes. The libmysql.dll does not display a version number, but is 1,302,528 bytes.

Can you list step-by-step in excruciating detail what I need to do to resolve this? i.e.

1. Start with php_mysql.dll 5.1.2.2
2. Copy it to nusphere\phped\php
3. Copy it to nusphere\phped\php5\extensions

etc. etc, etc.

I apologize for the trouble, but I really like what I see and want to purchase it, but I've can't go to my management while we're not connecting to databases.

Thank you for your help.
View user's profileFind all posts by gbutlerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
What php version you're working with?
PhpED comes with both php 4 and php 5 and depending on file extension and settings you have selected during installation, you may be working with either of them.
Just run phpinfo() and check the output.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 21 Mar 2006
Posts: 2
Reply with quote
Yep, it was defaulting to PHP4 when I was running a PHP5 system.

I did get it fixed, I ruan the phpInfo() and saw that it was 4.x, so I re-installed, ran the custom option and set the install to use PHP5 instead of the default 4.x, and it's working great.

I also noted that if a person is going to be running PHP 4.x, the php.ini in the /php directory does not have a extension entry for mysql -- you can copy the entry from the PHP5 directory, and that seems to fix it.

I am working on modifying a shopping cart that runs PHP4 on the web site but running PHP5 locally on a copy here. There were a couple of things I had to work through, but it's running great now and I love PHPEd. It makes working with PHP easy!

Sorry for getting irate earlier...

G
View user's profileFind all posts by gbutlerSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
Quote:
the php.ini in the /php directory does not have a extension entry for mysql

it's because mysql module is built in to all php4 versions. You don't need any "external" modules, only libmysql.dll
regarding php5, you still need both php_mysql.dll and libmysql.dll

Thanks for kind words regarding the IDE Smile
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Apr 2006
Posts: 11
Reply with quote
Could you please give us a link to download the dll file that we need. Also some breif instruction on what we need to do to make this workable? Thank you.
View user's profileFind all posts by cjacksSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8260
Reply with quote
I'd pick this http://dev.mysql.com/downloads/connector/php/
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Can't connect to mySql while debugging... *solved*
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic