NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
19321 ssh stuck [RESOLVED]


Joined: 29 Mar 2018
Posts: 37
Reply with quote
I upgrade from a 192xx version and all hell has broken out,
Firstly I accept that I need to re-enter a licence key.
But,
I lost my IDE interface customisation.
I lost my ssh details.
It took 45 minutes to parse a remote project by SFTP that used to take nanoseconds.
It periodically decides it wants to parse a file even before deleting it so 15 minutes later I am waiting to see if the file is deleted or not as the scroller snails its way across the dialog.

Can I un-install this upgrade and put a previous 192xx version back on?

Something is wrong and I don't know what, everything was superb using the 192xx version apart from the bug in the finally stanza of a try,catch,finally clause.

Any advice really gratefully received.

Kind regards,

jB Cool Evil or Very Mad
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
45 minutes and lost settings - neither is acceptable nor expected. In my tests 19.3 starts up faster than 19.2 with large projects, like the magento-based.
What is available memory in your system? What is CPU utilization? What are the processes that takes the most amount of memory or utilize CPU? Is it still taking 45 minutes each time you run the IDE or it was a one-time issue? Can you restart and check with freshly rebooted system?
If you don't see anything unusual in Task manager, you have to check your antivirus, especially if it is Kaspersky and especially if it is in "proactive" mode, but the other AV may also affect your system as well, and it wouldn't be reflected in Task manager because all nasty activity is happening in OS kernel. Sandboxed- or semisandboxed execution of what you downloaded from internet can not be fast. If that's the rootcause, I'd suggest to try different mode of AV or just whitelist the product.

It is not expected to lose any customization or ssh details. We check that that upgrade from old versions like v10 and fresh like v18 works good. Is there chance you uninstalled 19.2 and did not agree to keep settings while uninstalling it?
and what are the "ssh details" you lost? V19.3 brings support of new Key Exchange algorithms like Deffie Hellman group 16 and 18 and Curve 25519, also it supports now 25519 keys and adds them to the key list in "SSH Defaults". BTW is there chance you mean "SSH Defaults" instead of "ssh details"?

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Jun 2019
Posts: 20
Reply with quote
I've just extended my license for another year and upgraded to 19.3
There were no problems, everything from 19.2 were preserved after upgrade
View user's profileFind all posts by dp41646Send private message
Had to remove prior version


Joined: 29 Mar 2018
Posts: 37
Reply with quote
In order to get anything to work I have had to completely remove my previous version and install the new 19321 version.

Obviously I have lost a number of customisations I made but I am slowly getting those back in place.
Under previous versions I had various JavaScript libraries installed under
C:\Users\xxx\AppData\Roaming\NuSphere\PhpED-1920\config\Libraries\js
There does not seem to be a
C:\Users\xxx\AppData\Roaming\NuSphere\PhpED-1930\config\Libraries\js
and the latest 193221 is not picking up the added libraries.
Once I get that and all my snippets back I should be good to go, I hope.

Any advice on restoring the libraries would be gratefully received?

FOUND - C:\Users\xxx\AppData\Roaming\NuSphere\PhpED\config\Libraries\js it drops the version number.

kind regards,

jB Cool


Last edited by britesc on Wed Jun 03, 2020 11:02 am; edited 1 time in total
View user's profileFind all posts by britescSend private message


Joined: 29 Mar 2018
Posts: 37
Reply with quote
Nope slow as ever

It is a brand new installation and is so slow calling up dialog boxes all over the place.
I use an Ubuntu VM 18.04 as my development server.
As a development server all code is on that server and not on a local machine.
Many moons ago I used a mapped drive, but the debugger refused to work so I replaced the connection with SFTP
That seemed to work fine for 192xx but every-time I try to use 19321 it throws up a dialog "Checking NAMEOFSFTP" it shoots along for about 3/4 of the dialog box then takes about 30-45 minutes to parse the rest.
If I want to make any changes to settings it throws up the dialog box again.

I am about at my wits end as it is unusable now,
I would go back to a 192xx version but the serial number has gone from my account leaving me with only the 19321 serial number

I am at a loss on what to do.
Something has changed between 192xx and 19321. HELP

regards,

jB Cool
View user's profileFind all posts by britescSend private message


Joined: 30 May 2006
Posts: 55
Reply with quote
britesc wrote:
Nope slow as ever
As a development server all code is on that server and not on a local machine.


Is this not the root of the issue?
One cannot expect that real-time synchronization between local & remote files will be fast.
All depends on the number of files - even a simple framework directory slows down sync notably.
I would use sync FTP/SFTP exclusively for pushing release out to live/staging server.

I would suggest to move to develop on local filesystem - works natively, no directory mapping, fast for PhpEd, git and vagrant and docker ..
Just install WAMP server on windows, so you can also switch between PHP / apache / mysql versions ..

But if you still prefer sync development against remote filesystem, you may also use 3rd party tools e.g.
- WinSCP / SCP
- rsync

htt ps://winscp.net/eng/docs/task_keep_up_to_date
htt ps://www.youtube.com/watch?v=ndvEYOQLc4c
htt ps://stackoverflow.com/questions/20244585/how-does-scp-differ-from-rsync

Mapping linux directory via samba works too, but is waaay complex, I would not go with it anymore.
If you really need for some reason linux environment, then it's better to build up vagrant machine, which maps local windows directory into linux - works very fast and debugger can be configured using DBG wizard.
View user's profileFind all posts by lubosdzSend private message


Joined: 29 Mar 2018
Posts: 37
Reply with quote
HI lubosdz,

Thanks for the reply.
The setup worked in 192xx and was really fast, so why should upgrading to 19321 turn it all on its head.

Development has to been done on a development server not on local machines, which defeats the object of the Development, Test, Production Server Environment.

I will experiment further with tunnels etc...

Kind regards,

jB Cool
View user's profileFind all posts by britescSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
I checked 19.2 and 19.3 against Ubuntu 18.04 in Vmware. Smart Sync - download of all 5K+ files took 14 seconds in 19.2 vs 14 seconds in 19.3. Next iteration was 9 seconds vs 9 seconds -- disk was cached. No difference between versions. Update of all files showed no difference either.
Perhaps you can try the IDE on a clean machine without any other 3rd party software like antiviruses (Window's built in is okay). Alternatively, you can share your Vmware image with me and I'll check what's up there.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Site Admin

Joined: 13 Jul 2003
Posts: 8106
Reply with quote
Well, figured out what's going on. Problem can be reproduced in 64bit mode with full optimizations turned on only.
Root cause is bug in Borland CBuilder/Delphi compiler. Upper 32bits of a 64bit argument passed to function remain uninitialized. It wasn't easy to catch this problem:




You can try 32bit version of 19321. It works good.
As of 64bit, hope workaround will be found soon.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 30 May 2006
Posts: 55
Reply with quote
Uff & waaaw & respects, Dmitri!
View user's profileFind all posts by lubosdzSend private message


Joined: 24 Jun 2019
Posts: 20
Reply with quote
I can confirm - ssh on 32bit version is working normal
Thx
View user's profileFind all posts by dp41646Send private message
Astounding


Joined: 29 Mar 2018
Posts: 37
Reply with quote
Congratulations.
What an outstanding achievement.
What to me is most inspiring is that you took the word of someone at face value and investigated as deep as you have done.
I cannot commend you enough.

In the interim I mapped a drive between the server and my laptop and am using that to work. Apart from on 2 occasions locking up the application after a new file with content is created. Now I know I can live with that by create, save, work.

Now all you have to do after fixing this is to fix the indentation problems with reindent on the finally clause of the try, catch, finally stanza.

Millions of Kudos.
Kind regards,

jB Cool
View user's profileFind all posts by britescSend private message
19321 ssh stuck [RESOLVED]
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic