NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHPEd does not receive focus when debugger kicks in


Joined: 01 Aug 2014
Posts: 40
Reply with quote
@dmitri

Ever since I installed b20037 I noticed the following behaviour change.

I use putty to run a script that contains one single line:

<?php debugbreak('123@myDevWorkstation:7777;d=1,p=0,c=0');

PHPEd debugger kicks in, however the focus remains on the putty window where I executed the script.

That was not the case before. Previously, ALWAYS, soon as debugbreak() triggers, PHPEd would receive the focus and I could step through code without having to click PHPEd window first.

This is EXTREMELY annoying, any idea why this started happening?

Thanks
View user's profileFind all posts by temuri416-v2Send private message
Site Admin

Joined: 13 Jul 2003
Posts: 8336
Reply with quote
It may have something to do with OS changes / updates. We didn't change this in v20 or any version or build around it. PhpED just calls SetForegroundWindow() like it always do. But there is AllowSetForegroundWindow() that if called on the Putty side, would allow it to make OS ignoring focus transfer requests and focus would remain in Putty window. Did you update Putty? Can you call from cmd.exe window?
At least it works fine for me under vanilla Win7.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHPEd does not receive focus when debugger kicks in
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic