NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Code Navigator problem


Joined: 04 Nov 2019
Posts: 8
Reply with quote
Hi,

The Code Navigator doesn't work. Code Insigth/Include refresh doesn't help.
[img]https://drive.google.com/file/d/1n9kul9nyMJjNoodr_4E0yPfecOn-vcSl/view[/img]

Help!

pv20038
View user's profileFind all posts by radiySend private message
Re: Code Navigator problem


Joined: 04 Nov 2019
Posts: 8
Reply with quote
Hi,

I found why this happened. If, before opening the editor, “JS” was selected and “Auto Switch” was turned off.
"Refresh" doesn't help. It turns out that the CN can only be seen when "Auto Switch" is turned on.

[img]https://drive.google.com/file/d/1KRd_DXvJEYqZEtkPMEPG-1XE847jdC2I/view[/img]
View user's profileFind all posts by radiySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8335
Reply with quote
Hi Radiv, I'm not sure what problem you faced with. If your code contains JS, like some javascript code in script tag in HTML part of your PHP script, then CodeNavigator would show it on the JS tab. Otherwise the tab remains empty.
If Autoswitch feature is on, CodeNavigator follows current cursor position and switches tabs for you when you move from php to js or back. Refresh is about re-fetching parser results in case if for any reason CodeNavigator contains some stale information. Under normal circumstances as long as shown tree is displaying actual info from the parser, Refresh shouldn't change anything.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Code Navigator problem
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic