NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Why does DBG try to connect to 79.214.171.110?


Joined: 24 Mar 2010
Posts: 39
Reply with quote
Why does DBG try to connect to 79.214.171.110 even if debugging is disabled?

PHP Warning: Failed to start DBG session, reason: "connection to the client at clienthost (79.214.171.110) is not allowed in php configuration (php.ini)", check http://www.nusphere.com/dbg/?err=-100 for troubleshooting in phar:///usr/local/bin/composer/src/Composer/Util/ErrorHandler.php on line 51

79.214.171.110 is not an address of mine.

TIA
Eutychus
View user's profileFind all posts by eutychusSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8190
Reply with quote
Let me explain it a little be how it works. You're running IDE on your development host and you want to debug scripts running on single or multiple sites (webs or not it does not matter) -- let's call them your web servers. From these perspectives your development host running IDE is the server that hosts debugger listener and your webs are debugger clients that connect to the IDE on your development host. Direction is critical here -- your web servers are connecting to the development host. When you run debug session, IDE runs web browser (or terminal for CLI), passes URL (or command line) and debugger on the web site recognizes that request, connects back to the IDE and let you debug your script line by line. Then it finished, browser received web page and now what? Suppose you're debugging some form and you want to click on a button on that form and continue debugging the script with submitted data. To support this kind of continuous debugging, debugger has "debug session" option. When it's on, debugger emits DBGSESSID cookie that lives in browser and valid for all requests you're running on that particular domain. So if you click a button or link on debugged page, browser sends this cookie and debugger on the web site side recognizes it the same way as request from the IDE itself. If cookie received, your browser keeps it until you turn that option off and run at least one session with that option being off, or until you somehow else clean that cookie up. For instance you can add DBGSESSID=-1 http get argument to URL, run it, and cookie will be removed. In some extents it's explained in FAQ http://www.nusphere.com/kb/technicalfaq/howto_run_dbg.htm

Regarding your particular case, my understanding is that this is your IP address (Hello Germany, hope you're doing good!). Debugger found request and tried to reach the IDE side to start debugging your script. In this course of actions it first checks its own settings to make sure that the IDE ip address is in the allowed list. By default all addresses are allowed, but it's very easy to disable all and enable some particular addresses (see debugger.hosts_allow and debugger.hosts_deny settings). So it found out that the IP is not allowed, but the request is nevertheless here, so it posted error in the output.
If I get it right, the request was initiated by phar:///usr/local/bin/composer/src/Composer/Util/ErrorHandler.php script on line 51 -- there must be something like DebugBreak('clienthost') function call
Probably you want to re-visit this line and remove that call. Or you can allow IP address to check what happened in ErrorHandler.php and what led to DebugBreak call.
I'd also suggest you to switch to ssh port forwarding. See ssh tunnel settings -- in this case debugger will use only 127.0.0.1 or ::1 -- localhost. You won't need clienthost in DebugBreak() call, just localhost or 127.0.0.1.

Quote:
79.214.171.110 is not an address of mine.

Hmm, nevertheless this forum board received your post from this IP address. You can double check with your ISP or your company what is your public IP address (or check google for that).

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Mar 2010
Posts: 39
Reply with quote
I do understand all of this (or maybe I think).

But in this case. For the called website the debugger is disabled and phpinfo shows this as well.
View user's profileFind all posts by eutychusSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 8190
Reply with quote
Quote:
connection to the client at clienthost (79.214.171.110) is not allowed in php configuration (php.ini)

^^^ debugger did not try to connect. It identified IP address from request, checked allowed list and blocked itself returning error.
What you can do is
- remove request -- delete DBGSESSID cookie containing clienthost (that translated to 79.214.171.110)
- update project settings to ssh port forwarding (ssh tunnel) so it will start using localhost instead

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Why does DBG try to connect to 79.214.171.110?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic