NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Which PHP 7 version is currently included?


Joined: 04 Apr 2017
Posts: 8
Reply with quote
Hi,

When was the latest update to PHPEd? When I Check for New Version from the menu, it just says

Sorry, PhpEd version is not checked for long time.



So, I guess it's really two questions

1) What is the latest PHPEd version? Mine says 18.0 (Build 18030)

2) What is the latest PHP 7 version? I'd like to use 7.16, if possible.



I'm actually having problems loading the Sql Server drivers, even though they've all been registered, copied to the extensions folder, and referenced as extensions in the php.ini file. I'm trying to pin down the cause, by first making sure all of the versions are up to date.
View user's profileFind all posts by NSUserSend private message
Guru master

Joined: 24 Jul 2009
Posts: 709
Reply with quote
Just checking my account and looks like 18033 is the latest.

The version of PHP 7 with that is 7.0.15

Myself I never use the PHP versions that come with PhpED except sometimes when doing a bit of CLI.

For web sites I recommend a separate web server (eg Apache) and you can install latest stable builds of PHP.
View user's profileFind all posts by plugnplaySend private message


Joined: 04 Apr 2017
Posts: 8
Reply with quote
Thanks, plugnplay,

I've used both the internal server for PHPEd, as well as IIS 7.

There are definitely compatibility differences in the sql server drivers for PHP 7.0 vs 7.1, so it's probably best to stick with 7.0x, based on your assurance that PHPEd has 7.0.15 right now.

Unfortunately, there are other problems I haven't been able to resolve (referenced in another thread). But knowing the actual version that PHPed is using, simplifies the process somewhat.


Now that I think about it, I can just go into the PHPEd Program Files folder, to each installation of PHP, and get the version from the command line. Should be obvious, I guess.


Anyway, thanks for the pointers.
View user's profileFind all posts by NSUserSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
PHP 7.1 comes as an extra download on My Products page. If you install it, it will override php 7.0

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 04 Apr 2017
Posts: 8
Reply with quote
Hi dmitri,


You mean it will override the 7.0 configuration in NuSphere, but not overwrite it, correct?


The setup for php 7.1 for NuSphere, prompts that the folder C:\Program Files\nusphere\php71 will be created.


I'll go ahead and let it finish, thanks.
View user's profileFind all posts by NSUserSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
configuration, right.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Which PHP 7 version is currently included?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic