NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
*resolved* connection at localhost (::1) is not allowed


Joined: 17 Dec 2013
Posts: 13
Reply with quote
Hi

I am very new to PHPeD 11 and struggling to get the debugger program to work.

When I try to run a program throught the debugger I get

Reason: connection to the client at localhost (::1) is not allowed in php configuration (php.ini)

My PHP.ini file =

[XDebug]
;zend_extension = "C:\xampp\php\ext\php_xdebug.dll"
;xdebug.profiler_append = 0
;xdebug.profiler_enable = 1
;xdebug.profiler_enable_trigger = 0
;xdebug.profiler_output_dir = "C:\xampp\tmp"
;xdebug.profiler_output_name = "cachegrind.out.%t-%s"
;xdebug.remote_enable = 0
;xdebug.remote_handler = "dbgp"
;xdebug.remote_host = "127.0.0.1"
;xdebug.trace_output_dir = "C:\xampp\tmp"
zend_extension="C:\xampp\php\ext\dbg-php-5.5.dll"
[debugger]
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow=OU 127.0.0.1 192.168.10.4
#OU is the laptop on which the program is running
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16

The debugger port in the program is also set 7869

Not using ssh tunnel

Other settings

Web document Root D:\www
Web Root URL: http://localhost/
Root directory D:\www

http://www.nusphere.com/kb/technicalfaq/php_debugger_hosts_allow.htm

zend_extension="C:\xampp\php\ext\dbg-php-5.5.dll" is correct in php.ini

I have allowed the debugger program through the firewall in 7869

I have restarted the Xamp webserver


Please can someone recommend a solution?

Thanks for reading.
View user's profileFind all posts by kathekasSend private message
Guru master

Joined: 24 Jul 2009
Posts: 733
Reply with quote
The address ::1 is IPV6 whereas the addresses you have for hosts_allow are IPV4. Newer versions of Windows often default to IPV6.

Try using:

Code:
debugger.hosts_allow=OU 127.0.0.1 192.168.10.4 ::1


You probably do not need the OU there.

If your network is private & secure and not a public server, you can also use:

Code:
debugger.hosts_allow=ALL
View user's profileFind all posts by plugnplaySend private message


Joined: 17 Dec 2013
Posts: 13
Reply with quote
Thanks
View user's profileFind all posts by kathekasSend private message
*resolved* connection at localhost (::1) is not allowed
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic