NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
connection to the client at localhost (::1) is not allowed


Joined: 03 Feb 2008
Posts: 30
Reply with quote
I can debug my scripts fine if I set PhpED to use PHP v5.2.

But when I change to PHP v5.3 or higher, no matter what I do I get this error:

DBG 6.1.7

Failed to start DBG session

Reason: connection to the client at localhost (::1) is not allowed in php configuration (php.ini)
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.

Debugger request: "417157864631100021;d=1,p=0,c=1"
Request found in: "query_string"
Target PHP version: "5.4.x"
Server API: "CGI/FastCGI"
Extensions API: "220100525"
Modules API: "20100525"
PHP API: "20100412"

I have run the Projext Wizard 100 times and it says everything is fine. But my scripts won't run the debugger in PHP v5.4

PhpED tells me "Failed to start debug session. Please make sure that debugger module is installed for locally running php.

I have read the instructions for installing the debugger module, but I can;t get it to work. If I unchecked "Debug sessions" under Tools - Settings, then the debugger ran, but it would not debug all files throughout my session. So I checked it. But now the debugger won't run.

Please help me - I am very frustrated. This was working for me last week, but something is now goofy. Thank you.
View user's profileFind all posts by a_edwallSend private message
Guru master

Joined: 24 Jul 2009
Posts: 724
Reply with quote
Looks like an address issue relating to IPv6. An edit of your PhpED debugger settings to allow ::1 in the relevant php.ini might fix, but you would need to confirm which php.ini and show us those settings so we can review.

That linked page http://www.nusphere.com/dbg/ does also contain a few tips - have you looked through that?

For the moment you could also try unticking Enable IPv6 in the PhpED Run & Debug Settings. Older PhpED settings had an option to change the client address (eg to 127.0.0.1 to force IPv4), but can't see that any more and wonder if that tick replaced it.
View user's profileFind all posts by plugnplaySend private message
connection to the client at localhost (::1) is not allowed
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic