NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debugger channel is encrypted with: AES256-SHA/256b


Joined: 30 May 2006
Posts: 33
Reply with quote
Hi,

recently I have upgraded to newer version of NuSphere and I have noticed, that debug sessions are running pretty much slower.
After checking, I have found, that this might be caused by some kind of new encryption for debug data:

Code:
Debugger channel is encrypted with: AES256-SHA/256bits


Since I use virtual machine on a single computer I dont need any encryption, but would like to have previous speed back.
Is there any way to turn off this encryption?
Because I dont see any other reasong what might cause this slowness.

Using PHP 5.5.8 (php-fpm + nginx) + DBG v6.1.4, centos 6.4 on samba shared directory.

Thank you.
Lubos
View user's profileFind all posts by lubosdzSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
AES256 is quite fast cypher and can't hardly cause deep problems with performance.
More than often, the problems are caused by just _large_ amount of data to transfer, and slow software that monitors traffic (firewall/antivirus).
If you want to disable SSL, just diable it on the server using debugger.ssl=0 (don't forget to restart web server to get new settings in effect)
If you want to minimize amount of data the debugger transfers with each step, disable Locals and Globals. Delete all unneeded entries in Watch and disable or delete all undeeded breakpoints.
Also check for a better firewall/antivirus.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Debugger channel is encrypted with: AES256-SHA/256b
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic