NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PHP CLI debug output window is empty


Joined: 15 Nov 2013
Posts: 3
Reply with quote
I just installed latest version of PhpED and getting familiar with it. I am used to work with zend studio, so I am not sure if I understand the right purpose of "Output" window for debug. No matter what I do, there is no output generated into this window. When php CLI is set to "no window" there is returned "IDE Php-cli error output:" with empty error in Log window, when I turnd it to "External window", then no error occured, but output window remains empty. In the cmd window all runs fine. I tested it on string echo and phpinfo().
Am I doing anything wrong?
View user's profileFind all posts by GoodwillSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Output window is expected to show the output produced by your script that is sent to the output stream. It may not appear immediately upon each echo or print statements are executed because of the output buffering that is turned on by default.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 15 Nov 2013
Posts: 3
Reply with quote
I turned off buffering in php.ini of course, does not show anything. All php.ini files in all php versions I have found in phped folder have set output_buffering = Off. What next?
View user's profileFind all posts by GoodwillSend private message


Joined: 16 Aug 2008
Posts: 29
Reply with quote
Try ob_get_level() to check that all OB are really turned off. There may be more of tham e.g. output compression.
View user's profileFind all posts by odinuvSend private message


Joined: 15 Nov 2013
Posts: 3
Reply with quote
Returns 0. I have to say, that I have used last version as-is on other computer with same result, doesnt work by default.
View user's profileFind all posts by GoodwillSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
if you have a script reproducing the problem, please submit report to NuSphere Support

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
PHP CLI debug output window is empty
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic