NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
xdebug crashed my Wampserver *resolved*


Joined: 30 May 2012
Posts: 7
Reply with quote
Clean installation of Wampserver on either XP Pro or Windows 7 machines. All tested and running php programs without problems.

Enter PhpED and disaster. As soon as I try to set up a new project I get to the stage 'Checking PHP Installation' and it reports:- Error:(-104) failed to connect to webserver ("http://localhost/").

After closing PhpED, Wampserver still appears to be running but now none of the web browsers can access localhost and I have to remove and re-install Wampserver! Crying or Very sad

What is the matter with PhpED?
View user's profileFind all posts by oldceltSend private message


Joined: 30 May 2012
Posts: 7
Reply with quote
OK, I'll answer my own question. Took 3 hours of analysis but, in the end, realised that Wampserver and PhpED debuggers were both trying to load and conflicting with each other.

To fix this problem, go into php.ini (Wampserver) and comment out the load of XEDEBUG - sorted!

Shame this isn't highlighted in PhpED installation!
View user's profileFind all posts by oldceltSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
yep, it's known that some versions of xdebug will crash apache if dbg debugger is installed.
what you need is change the order they are loaded or comment out xdebug.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 30 May 2012
Posts: 7
Reply with quote
Already done that. As I said, pity it isn't highlighted during phpED installation.
View user's profileFind all posts by oldceltSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
I don't see any relation between PhpED installation and your Wamp server.
PhpED does not install anything to 3rd party software. It comes with its own http server and 3 versions of php.
Since WAMP is never touched, I don't see why would installer snoop into Wamp settings and warn about anything discovered.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 30 May 2012
Posts: 7
Reply with quote
So how come phped's debugger is inserted into the wamp setup .ini files? Only phped could have done that!
View user's profileFind all posts by oldceltSend private message
Guru master

Joined: 24 Jul 2009
Posts: 732
Reply with quote
I can't say I've ever seen PhpED update a php.ini file on any web server. Is it capable of doing that? I didn't think it was, which was why the Debug Wizard gave instructions.
View user's profileFind all posts by plugnplaySend private message


Joined: 30 May 2012
Posts: 7
Reply with quote
OK, if you'd like to try it do this:-
Make a clean installation of WAMP server on a PC. Run any .php program you like from localhost; open phpMyAdmin and add a database; log out. Run a .php program to access the new databse - all works impeccably.

Now start a new project in PhpED and set it to use WAMP (one of the project options in PhpED). It will report that localhost is inaccessible. PhpED has added its own debugger to the WAMP apache php.ini file and that screws everything up.

Either remove the PhpED debugger oir XEDEBUG from Apache' php.ini file and order is restored.
View user's profileFind all posts by oldceltSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
I'm not sure how this
oldcelt wrote:
Already done that. As I said, pity it isn't highlighted during phpED installation.

matches the following:
oldcelt wrote:
...start a new project in PhpED ...


With Project Wizard, it's indeed possible that your php.ini will be modified (with appropriate warning given).
So you can't be unaware of the changes. In other words -- Wizard warns (highlights!) about modifications.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 31 Oct 2013
Posts: 1
Reply with quote
Hi Guys
I'm a new user here and I know this is a bit of an older topic but I had the exact same problem and have just managed to fix it this morning.
If this helps anyone this is what I found.
Phped 10 does add lines to the php.ini file and it was here I found the problem.
In the php.ini file at the bottom of the file was 2 lines starting with zend_extension, one line was the path to xdebug and the other line was the path to the dbg module that Phped 10 inserted. It is a must that the line with the dbg module comes first and the xdebug line second.

Also under the zend_extension lines are some settings one of which reads something like *****HOSTS_ALLOW=127.0.0.1. (Unfortunately I dont have my laptop with me with the file on it so I am trying to remember what the first part of the line read, but you will see it.)
It should read like this ******HOSTS_ALLOW=127.0.0.1 localhost ::1

Save the file and restart all servers and you should be good to go.
I hope this helps others, it does seem to have fixed my problems
I am using windows 7 PHPED 10 and wampserver 2.

Cheers
Darryl.
View user's profileFind all posts by critchSend private message
xdebug crashed my Wampserver *resolved*
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic