NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
code compeletion not working completely


Joined: 24 Sep 2013
Posts: 1
Reply with quote
Hi,

I have added some functionality to some class. But not all fuctions show in the code completion box.
I had about 6 function implemented and it worked fine, but after that when i added more (static) functions they won't show in the dialog box.
The ones i had before still are available, only the new methods are missing.
Any idea ehat this could be?

thnx.
View user's profileFind all posts by martijnjonkersSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
I'm not sure what statics you mean.
With the following example everything works fine:

Code:
<?php

class abc {
  static function def() {
   echo "hi";
  }
}

$a = new abc();
$a->| // <- code completion invoked here shows abd::def()

?>

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Guru master

Joined: 24 Jul 2009
Posts: 717
Reply with quote
Maybe right-click on the Code Explorer panel and do a Refresh?
View user's profileFind all posts by plugnplaySend private message
code compeletion not working completely
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic