NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
trouble uploading files via FTP


Joined: 27 Nov 2007
Posts: 12
Reply with quote
Was running PhpEd 8.1 fine for quite a long time. I upgraded to 9.0 (Build 9051) by installing right on top of the 8.1 install, thus preserving all my settings. Each project has several local folders mapped to the appropriate remote server directory. And, I have an FTP account set up to use to FTP transfer the fiules during upload. again, this all worked on 8.1. Now, when I edit a file, I save with CTRL+S, then I try to upload with CTRL+SHIFT+S. PhpEd seems to think the file uploaded successfully. When I look in the Transfers window, I see my file. The local path (From) and remote path (To) are absolutely correct. Info suggests something like 208kB transferred, 2.20MB/sec, and the Status says Completed. Yet, the file is not updated on the remote host. I can open the file using the Edit+ editor and upload the file, using the same FTP credentials, and the file is uploaded fine. So, I know my FTP account is working, and FTP is working on the server. I can't find any tools in PhpEd to help me troubleshoot this. It's a valuable feature that I depend on.

Any help would really be big. Thanx so much.
View user's profileFind all posts by blairwagSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
Check root directory in the account settings -- it should be '/' or something appropriate for your environment, then press [OK] button to save changes.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 27 Nov 2007
Posts: 12
Reply with quote
Holy cow! That was it! Thank you SO MUCH!
View user's profileFind all posts by blairwagSend private message


Joined: 08 Oct 2007
Posts: 32
Reply with quote
You have a bug here, i upgraded my phped 7.0 to the last one and before it worked but not anymore, i use it every days.
i reverified paths and login with account all is ok on my dev pc and server.


Ps: Can I install phped 7 over phped 9 ?


Last edited by xaff on Fri Jul 05, 2013 3:02 am; edited 1 time in total
View user's profileFind all posts by xaffSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
@xaff

There is no bug. I'm sorry if "account settings" words didn't reach your eyes. Try tools->settings->accounts, open your account, enter Root directory, for example /, then press [OK].

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Oct 2007
Posts: 32
Reply with quote
my root directory is / and I repeat it work with the phpEd 7.0, how do you explain that ?
View user's profileFind all posts by xaffSend private message


Joined: 08 Oct 2007
Posts: 32
Reply with quote
hum there something very strange here, cache maybe, I was able to make it work, there is my actions:

opened Accounts (my root is /) > unchecked cache > ok > ok > tried: still not work
opened project properties > double click To publishing target > changed /home/myproject by home/myproject (may be It don't like // anymore one root dir one in path ? anyway) > ok > ok tried: still not work
opened project properties my Top publishing is still /home/myproject (it correct my changes i suppose) > double click To publishing target > opened Accounts my root became "" ?? so I set it to / > ok > ok > tried: it works !

Problem solved for me I don't really know why, mybe this procedure could help some peapole.
View user's profileFind all posts by xaffSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7875
Reply with quote
Once again to make it clear -- you don't need to do anything with any other settings, just root directory. Enter / here and press [Okay], nothing else.
If you don't enter / or don't press [Ok], nothing will change. The problem is that previous versions didn't save root directory properly.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
trouble uploading files via FTP
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic