NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Remote debugger version mismatch


Joined: 29 Mar 2013
Posts: 17
Reply with quote
I have PhpED 9.0 Build 9037 installed and it comes with the 4.6.4-Linux.tar.gz in the "server" directory. The project wizards states that I should update to 4.6.5. Where do I get the remote dugger version 4.6.4 to match my local install?
View user's profileFind all posts by pcuniteSend private message


Joined: 29 Mar 2013
Posts: 17
Reply with quote
Here is a screen shot of the error.

View user's profileFind all posts by pcuniteSend private message
Guru master

Joined: 24 Jul 2009
Posts: 717
Reply with quote
You will possibly find it debugs just fine but it is a good idea to update.

I've often debugged with mismatched debuggers, suspect I am at the moment, so I really should update myself Wink

Various dbg modules will be found in your program files PhpED\debugger\server directory.

You probably need PhpED\debugger\server\dbg-4.6.4-Linux.tar.gz and file dbg-4.6.4-Linux\x86_TS\dbg-php-5.3.so

If you need SSL dbg then that is a separate download from your NuSphere account. Debugging locally is unlikely to need SSL.
View user's profileFind all posts by plugnplaySend private message
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
Well, pcunite obviously already found the "server" directory and the files for version 4.6.4, but according to him the project wizard tells him to update to version 4.6.5. Neither in Build 9039 nor in the current SSL package version 4.6.5 can be found.

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message


Joined: 29 Mar 2013
Posts: 17
Reply with quote
Quote:
Well, pcunite obviously already found the "server" directory and the files for version 4.6.4, but according to him the project wizard tells him to update to version 4.6.5. Neither in Build 9039 nor in the current SSL package version 4.6.5 can be found.


This is correct. I don't know how to obtain the mythical x.x.5 version of the debugger.
View user's profileFind all posts by pcuniteSend private message
Guru master

Joined: 24 Jul 2009
Posts: 717
Reply with quote
I see your point. The SSL version is also 4.6.4 and that appears to have been out since Nov-2012.

I guess its one of those messages we can ignore for now. Confused
View user's profileFind all posts by plugnplaySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
Yep, you can ignore them.
We updated only dbglistener this time and this caused version mismatch.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Remote debugger version mismatch
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic