NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Integration between PhpEd and Polystyle


Joined: 12 Jul 2012
Posts: 3
Reply with quote
I just bought the pro version of Polystyle because the trial version that comes with NuSphere PhpEd was doing a great job in making some code more readable.

However I noticed that the Polystyle website does not have any information on how to integrate Polystyle with PhpEd, and the help file that comes with PhpEd provides basic information about the integration.

However when I launch the Polystyle tool (from PhpEd) by right-clicking on a css file header and selecting "Format text with Polystyle", I get the following error message:

-----
Unable to find XKRN31532.DLL (referenced from F:\Installed Apps\Polystyle\internal\polystyleRunner.exe). If you compiled executables to other machines, please, use the Jetpack II deployment utility (see JET User's Guide, "Deployment Automation" for details).
-----

Note that I have so far:
1. Added the path to polystyle.exe to the OS PATH (and confirmed that I can launch Polystyle from command line)
2. Added the path to polystyle.exe to NuSphere PhpEd Tools-menu > Settings-dialog > External Tools -option > Polystyle-field.

I have not:
A. Altered the out-of-the-box setting for Polystyle integration in PhpEd that is located in NuSphere PhpEd Tools-menu > Settings-dialog > Integration -option > "Format text with Polystyle"-entry.

My system details are as follows:
OS: Windows 7
PhpEd: v.7 build 7021
Polystyle version: 4.0d - Professional edition

Polystyle is installed on the F-partition, the reason is that a note on the Polystyle website (http://www.polystyle.com/doc/) states that:
(Note to Vista and Windows 7 users: You may need to install it somewhere other than program files, such as your user directory, for it to work because of the permissions.)


If anyone has dealt with and solved this issue before I would appreciate hearing what the solution to it could be.

Many thanks

JJ
View user's profileFind all posts by jjoensuuSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
I'm not sure why you're addressing this issue to this forum. Please contact Polystyle authors and ask why THEIR executable can't find THEIR dll. PhpED does absolutely nothing to hide this dll. It just runs the exe as any other exe. Nothing uncommon. BTW 2.0z worked fine as you probably noticed.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Integration between PhpEd and Polystyle
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic