NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
custom syntax colors lost after upgrade


Joined: 11 Nov 2007
Posts: 11
Reply with quote
Hi there,
today I installed the evaluation copy of phped 7 over my good old 5.9
Now I miss my custom syntax colors.

How can I get them back?
View user's profileFind all posts by mifeSend private message


Joined: 11 Nov 2007
Posts: 11
Reply with quote
Does this silence mean I should forget about it?
View user's profileFind all posts by mifeSend private message


Joined: 11 May 2008
Posts: 78
Reply with quote
You should have backed them up beforehand. This is true even between minor version upgrades. I write up my most important settings and colors in a file or screenshots, then restore them. Slow but time- and interversion-proof. You can look in the phped folders to check if they are to be found in some old file but I wouldn't cross my fingers on that.
If you had made some screenshot of your IDE sometime in the past, try to match them as close as you can or with the eyedropper in Photoshop.
As to the silence, get used to the fact. For some reason only Dmitri is among the admins and/or devs who are answering here from time to time and it seems on rare occasions.
View user's profileFind all posts by tedychSend private message


Joined: 06 Jul 2009
Posts: 72
Reply with quote
I assume the custom colours were originally setup for PHP5.2 rather than PHP5.3 in the settings. From 6.x, the separate 5.2 and 5.3 settings were dropped in favour of a single PHP setting... but this IIRC, actually inherited from the 5.9 PHP5.3 settings rather than 5.2.. so you'll need to reconfigure them unfortunately.



Cheers..

Ian
View user's profileFind all posts by Ian.HSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7894
Reply with quote
Ian.H wrote:
IIRC, actually inherited from the 5.9 PHP5.3 settings rather than 5.2.


You're right. More than a year ago we swithced to single set of color settings for php coloring. Old versions had different settings for all three supported branches of php: php v4.x, v5.0-5.2 and v5.3. It wasn't convenient for users -- in face of supporting HTML 3.2/4.0/4.0frames/5.0, XHTML 1.0 etc, it would easily cause a headache to set them all.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
custom syntax colors lost after upgrade
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic