NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
were are Side by Side file viewer and Find Usage


Joined: 08 Oct 2007
Posts: 32
Reply with quote
Hello,

-For the Side file viewer :
I'm confuse here http://www.nusphere.com/products/side_by_side_php_viewer.htm? we can read : "select Show Differences item from a popup menu of File toolbar"

But there nothing like this in my File menu and in context menu i only have "compare with remote", where is excatly the command to compare 2 local files please ?


-For the Find Usage I didn't find any button like this, can you screen shot it please ?

thanks in advance
View user's profileFind all posts by xaffSend private message
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
Are you using the brand new version 7 of PhpED? These are new features that are not available in version 6.x.

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message
Re: were are Side by Side file viewer and Find Usage
Veteran

Joined: 02 Sep 2007
Posts: 116
Location: Kiel, Germany
Reply with quote
xaff wrote:
But there nothing like this in my File menu and in context menu i only have "compare with remote", where is excatly the command to compare 2 local files please ?

I just found some time to play around with the new version. You have to right-click on the tab of the open file (or on the empty space beneath it if only a few files are open) to open a context menu that contains the entry "Show Differences > Local File Differences".

Cheers,
Jan
View user's profileFind all posts by EnigmaSend private message


Joined: 08 Oct 2007
Posts: 32
Reply with quote
I'm on Version 7.0 (7021)

Enigma, I found the contextual menu with right click on tab Smile but "Local File Differences" opens the same file on both sides and I don't know how to specify an other file...
View user's profileFind all posts by xaffSend private message


Joined: 08 Oct 2007
Posts: 32
Reply with quote
Ps: for the "Find Usage Functionnality" I found some things :
- the contextual menu appears on a local var but not on declaration method name, anyway the shortcut crtl+F7 works.
- on a local var or on protected attribute it searches but don't find anything.
- on a method name (with crtl+F7) it works fine Smile.
View user's profileFind all posts by xaffSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
@xaff, I'm sorry to say that your report makes almost no sense here. Please find time to prepare a report for support and working with them until they are able to reporoduce the problem -- you may be asked for sample and screenshots. Forum is a thing where you can't work with support and therefore - posting any problems is a non-sense Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Oct 2007
Posts: 32
Reply with quote
I even didn't know if there a "problem", I may just have missed something.
View user's profileFind all posts by xaffSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
I can't belive you didn't know when you posted "- on a local var or on protected attribute it searches but don't find anything" Smile

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Oct 2007
Posts: 32
Reply with quote
Don't be affraid !!
PhpEd is still far the best ide for php developpment, at my opignion Very Happy
And you have all my congratulations for this new release with these amelios.

Now we talk here about realy new and early stage functionnalites, with no real finalised documentation about them.
So I prefer suppose that the "problems" are due to my miss-understanding about "what the dev team imagined", before pretend It's a bug or something like that (I'm shure you know what I mean Wink )
For example : about "find usage", when I saw it returns nothing, I thought maybe they think its useless because there is already the highlight vars functionality ...
View user's profileFind all posts by xaffSend private message
Guru master

Joined: 24 Jul 2009
Posts: 717
Reply with quote
Personally I do actually find it quite useful when others report 'bugs' or 'issues' on this forum.

Don't get me wrong, I support the requirement for bugs and issues to be reported using the contact form, but when a developer is very busy it is good if they understand that they shouldn't bother mucking around with something that might cause them issues.
View user's profileFind all posts by plugnplaySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
If developer is so busy to post a report using Contact Us, why he will be less busy reporting it on the forum? From the necessary time perspectives, the two ways are equivalent. If like you said developer is very busy, he won't answer - neither on forum, nor to the requests sent by the support. But, from the final-results perspectives, reporting using appropriate page is much better because these reports are received by support and at least a) thy receive it in time b) they receive only reports and nothing else, so they can focus on working with support request, and not spend time finding reports among other posts c) they know who posted report and can contact the reporter should they need to request further info such as screenshots and source files d) all requests are structured by the problems and management can monitor them and see clear picture.
On the other hand, forum is much better if the user does not know what he deals with. In some cases the "problem" is caused by wrong settings -- they work like they should, but not in the way the user wants them to, or he/she does not know what settings to apply.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Guru master

Joined: 24 Jul 2009
Posts: 717
Reply with quote
Hi Dmitri,

Last week I reported a bug which causes PhpED 7 to crash for me, sometimes as quickly as a few seconds after startup, sometimes after many hours. I did not mention that issue on the forum.

We have worked together to try and find the cause of that bug, with my using a debug build. However, that debug build wasn't allowing me to develop a large project (too slow + extra issues), so I've had to revert to a normal build.

Whilst others may or may not report that same crash to you, for me personally it would be useful to see if others are having the same issue and collectively we can sometimes find a common factor and solution. The Vista/Windows 7 64-bit sound control sort of problem.

By the lack of others not posting on this forum about crashes, I assume I am the only person getting crashes. Same issue with 7021 by the way.

Of course, now I mention it on the forum, are others suddenly going to say 'oh, I'm getting those crashes as well.'

I fully support the reporting of issues direct to NuSphere. You will have seen me mention that many times in various threads and I will continue to do so. But the forum is a powerful tool where users can work together to help resolve issues and it would be a shame to neglect that.
View user's profileFind all posts by plugnplaySend private message
were are Side by Side file viewer and Find Usage
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 2  

  
  
 Reply to topic