NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Bad Handshake mysql(err #1043)


Joined: 27 Mar 2012
Posts: 1
Reply with quote
Hello,
I have a problem.

DB Client does not connect to the database.
After setting up mysql account I receive an error
Quote:
Could not connect using: root@localhost
1043 - Bad handshake


Configuration:
Quote:

WebServer - Denwer on localhost
Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8k PHP/5.3.6
MySQL-client: mysqlnd 5.0.8-dev - 20102224 - $Revision: 308673 $

Please help me.
View user's profileFind all posts by darkksSend private message


Joined: 11 May 2008
Posts: 78
Reply with quote
I was unable to make a connection as well. MySQL 5.5. A message tells me to update the mysql client. I have memories of similar problems before which I seem to have been able to correct by replacing the mysql client libraries in phped.
If you don't want to go through the procedure, you can just use a much more potent standalone mysql tool, there are many, and mysql workbench is one of the best and free.
I have never found the built-in DB functionality to be of any use.
View user's profileFind all posts by tedychSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
the problem is with mysql which requires newer libmysql.dll
but mysql AB placed license which does not allow us to distribute this library... so...
the only solution for you is to replace the library with what you can download and install from mysql web site.

BTW, it's a FAQ topic
http://www.nusphere.com/kb/technicalfaq/faq_db_related.htm

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[resolved] Bad Handshake mysql(err #1043)
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic