NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
SANITY CHECK PLEASE: can't start dbg session,


Joined: 13 Jun 2004
Posts: 25
Reply with quote
Hi

I really feel that I've tried everything

1) I have a seemingly OK install on my remote server (PHP 5.0.0rc2) phpinfo shows 2.16.7, I used the correct .so

2) I've installed PHPEd 3.3.1 eval and the listener says that it's also 2.1.6.7

3) php.ini contains:

[debugger]
debugger.enabled=on
debugger.profiler_enabled=on

; commented out, both these resolve to my client machine
; but with this setting I get connection refused
;debugger.hosts_allow=europa-office, 10.0.1.109

; with this setting I get *almost* the same error "failed to connect to the client address 10.0.1.110:7869" but the "connection refused" bit is missing)
debugger.hosts_allow=ALL

debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16

4) connection is not thru ssh, this is an internal dev server with the client being 10.0.1.109 and the server being 10.0.1.110

5) hosts.allow and hosts.deny are empty

6) Telneting to client from server to the right port, the black dot appears in the listener and eventually in the log I get:

15/06/2004 12:20:26 10.0.1.110 client connected
15/06/2004 12:20:47 10.0.1.110 wrong client, disconnecting

7) if I telnet to the server at the same port I get connection refused

What have I missed please?

thanks in advance

Darren Beale


Last edited by bealers on Tue Jun 15, 2004 11:25 am; edited 1 time in total
View user's profileFind all posts by bealersSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Seems everything is okay. I see no problems so far.
Please proceed with http://forum.nusphere.com/howto-setup-project-properties-in-phped-t645.html
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 13 Jun 2004
Posts: 25
Reply with quote
Hi and thanks for the reply

I had already looked at the project settings and they seemed OK (to me at least), I've included them below as they may be useful.

Since posting I've had someminor sucess but I'm not sure why.

Under Settings -> Debugger I'e changed the Debugger Host to be auto rather than explicitly referring to the IP of the Server.

When I run a file thru the debugger now I get an error saying that it is unable to map a file to a local file

specifically:
/usr/share/php/lib.inc

This file is something that is auto_pepended using php.ini, I see the mapping section under projects but I don't see why I would need to map this file


=========== project settings ===========

I'm using Apache user dirs to have my own sandbox (user bealers)

doc root for http://myserver is /home/bealers/sandbox

/home/bealers is mapped to X\: over samba

So my settings:
Project = X:\sandbox\C\clickmetric\clickmetric.ppj
Root directory=X:\sandbox\C\clickmetric\codebase

Publishing (all blank)

Mapping
Run mode: 3rd Party web server
Root URL: http://myserver/C/clickmetric/codebase/
Remote root directory: /home/bealers/sandbox/C/clickmetric/codebase/

Files (all blank)
View user's profileFind all posts by bealersSend private message


Joined: 13 Jun 2004
Posts: 25
Reply with quote
I've done some more on this

Now I have commented out the auto_prepend and am running a helper script with just one local include file.

Project settings are unchanged from above and the file is within the project.

When I run the debugger I get an error saying:

"Failed to map file
/var/www/home/bealers/sandbox/C/clickmetric/codebase/_tools/test.php"

it seems to have prepended /var/www to it, that is the default doc root for apache granted but I'm running under a separate virtualhost mapped to my sandbox correctly. In the title bar it states "Output http://myserver/<correct URL to file>

I'm really confused. What is wrong? I really like the IDE and am considering buying it but the debugger is a pre-requisite to my purchase and I've spent a long time trying to get this working now.

Any ideas?

I still need to be able to get that auto_prepend file to run too. I did think about adding a mapping but that doesn't make sense, I can't map to it as it's not available through my share
View user's profileFind all posts by bealersSend private message
Talking to myself now


Joined: 13 Jun 2004
Posts: 25
Reply with quote
Ok, I've set up a test site that rather that using the userDir is a folder in the default doc root (/var/www) and it's working fine

AFAICT the project is set up the same so I'm wondering if this is an issue with using the user dir as my doc root?


from httpd.conf

<IfModule mod_userdir.c>
UserDir sandbox
</IfModule>

and my url that I posted a few posts above goes to /home/bealers/sandbox

Not sure what the issue is here
View user's profileFind all posts by bealersSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
You'd use documentroot anyways.
If you run multiple virtual hosts (distinguished by ports or hostnames) you may have multiple documentroot directories.
Anyways, UserDir has very little relation to that. It works for authenticated users only.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 13 Jun 2004
Posts: 25
Reply with quote
Quote:
You'd use documentroot anyways.
If you run multiple virtual hosts (distinguished by ports or hostnames) you may have multiple documentroot directories.


Yes, I do have multiple document roots, they are set up correctly and work correctly, however when I debug, all remote paths have /var/www prepended which is the doc root of the *defualt* virtualhost, as indicated above, hnce me mentioning it.

For the project I'm testing this IDE on the document root for that virtual host is /home/bealers/sandbox, when I debug I get an error saying that that /var/www/home/bealers/sandbox does not exist.

Quote:
Anyways, UserDir has very little relation to that. It works for authenticated users only.


Eh? that user has an account on the server granted (so they can access their work) is that what you mena by authenticated? ANy one can view the files over http, e.g. http://flump/~bealers will get to be doc root, I just happened to have added a DNS entry (which is used as the ServerName for the virtual host) that points to the same folder as it looks neater

I'm still in the situation that

1) The main issue is that when I debug /var/www is prepended to all remote paths

2) I have a file that is auto_prepended from within php.ini, this is *way* out of the document root of my project and should stay out of it. I did read the FAQ entires re: mapping but still doni't understand why a file in /usr/share/lib needs to be mapped to a project. If I try to debug, it complians about not finding the file.

I can turn off the warning but I still don't understand why it's complaining
View user's profileFind all posts by bealersSend private message


Joined: 13 Jun 2004
Posts: 25
Reply with quote
Embarassed

/home was symlinked and in /var/www, hence my problems
View user's profileFind all posts by bealersSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
Quote:
Yes, I do have multiple document roots, they are set up correctly and work correctly, however when I debug, all remote paths have /var/www prepended which is the doc root of the *defualt* virtualhost, as indicated above, hnce me mentioning it

debugger does never pre- pend nor post- pend pathes. It takes them from php engine and therefore debugger can't be wrong. If it sees /var/www/... it means that php executed /var/www/...

Quote:
For the project I'm testing this IDE on the document root for that virtual host is /home/bealers/sandbox

Make sure that you do test on that virtual host, not on the default one.

Quote:
1) The main issue is that when I debug /var/www is prepended to all remote paths

see above.

Quote:
2) I have a file that is auto_prepended from within php.ini, this is *way* out of the document root of my project and should stay out of it. I did read the FAQ entires re: mapping but still doni't understand why a file in /usr/share/lib needs to be mapped to a project.

It's the way IDE works. IDE needs to see all the files locally to avoid excessive network traffic during debug session.
To accomplish that you may copy this file to for example c:\work and add additional mapping entry that would bind c:\work (local path) to /usr/share/lib (remote path)
View user's profileFind all posts by dmitriSend private messageVisit poster's website
SANITY CHECK PLEASE: can't start dbg session,
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic