NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[PhpED 6 Bug] SFTP fail to connect


Joined: 08 Jun 2011
Posts: 5
Reply with quote
Ok I have already submitted a ticket on this one but though to also take the temp with the community if someone else can confirm this or contrary have sftp working in PhpED 6 (6026)?

When I try to upload a file, setup the dubugger and upload the debug script or simply connect to a site with sftp in Explorer frame by clicking the + to expand (= connect) I get an Error message "Packet corrupt Failed to connect to the server". Anyone else or anyone that have SFTP working in PhpED 6?
View user's profileFind all posts by 7sedmSend private message


Joined: 16 Jul 2009
Posts: 15
Reply with quote
I've also got a problem with sftp:

DH_GEX group modulus is NULL
Failed to connect to the server
View user's profileFind all posts by vvbSend private message


Joined: 08 Jun 2011
Posts: 5
Reply with quote
6027 = No Change and still waiting for a real person to respond to my support ticket. Ok it's only a tad hour beyond 2 days since I submitted the ticket, so no reason to start crying yet!

I know it has to be PhpED though because I have no problem to use sftp and connect to same account with my ordinary FTP client, using SFTP of course.
View user's profileFind all posts by 7sedmSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Did you read our change log and #3485 item in particular?
It means that you have to regenerate the keys if you're using public-key authentication.

and no, DiffieHellman kex group modulus can not be 0, it's a kind of bogus message from your server that I'd ask the server maintainers for.

for futher problem reports please use this form http://www.nusphere.com/contact_us

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 08 Jun 2011
Posts: 5
Reply with quote
dmitri wrote:
Did you read our change log and #3485 item in particular?
It means that you have to regenerate the keys if you're using public-key authentication.

and no, DiffieHellman kex group modulus can not be 0, it's a kind of bogus message from your server that I'd ask the server maintainers for.

for futher problem reports please use this form http://www.nusphere.com/contact_us


Been away for some time and this is still an issue in 6.1 and yes I read the change log but how do I regenerate the keys? I can't recall I ever have generated those keys myself to start with so it must have been done by the IDE as I only have the Default settings there. Well it must have done so as they apparently are broken, so why doesn't PhpEd regenerate them then or at least offer to regenerate them? Or if it now is as simple as just delete the current default settings to have the IDE regenerate there should have been some info telling this b/c as a user you shouldn't have to take the risk with such operation "in the dark" which may cause a lot of unforeseen mayhem.

And I did file a bug report earlier when this started bug no one has been close to suggesting the keys may be broken due to that (fixed) bug, just suggests to try the latest version which of course haven't been working.
View user's profileFind all posts by 7sedmSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
Been away for some weeks.

No, the issue is not still there. It's the keys are still broken. And you're correct -- deleting ssh defaults followed by restart the IDE will help.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[PhpED 6 Bug] SFTP fail to connect
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic