NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
dbg 2.14.9 - connection to client not allowed
Veteran

Joined: 16 Aug 2003
Posts: 101
Location: Montreal, Canada
Reply with quote
I have just installed phpED 3.2.1 eval, and for the life of me, can't figure out how to make remote debugging to work. There is not much information (that I could find), about the configuration directives for this new version, but they seem different, based on the various documentation I found on this site.

Everything works correctly when locally debugging on winxp (php_dbg.dll is in the right directory).

When trying to remote debug, I get

DBG

Failed to start debug session

reason:
connection to the client address xx.xxx.xx.xx:7869 is not allowed
(where xx.xxx.xx.xx is the address where phpED is running)

On the remote server (RH7.3, PHP4.3.2, Apache 1.3.27):
installed the new dbg.so file in the right location;
added this to php.ini:

debugger.enabled = true
debugger.profiler_enabled = true
debugger.hosts_allow = localhost, 127.0.0.1
debugger.hosts_deny = ALL
debugger.ports = 10000/16, 7869

and restarted apache. I've event tried adding my ip to the hosts_allow directive, to no avail.

phpinfo shows the debugger is enabled, among other things. Firewall is definitely NOT in the way.

Any help appreciated.

Martin
View user's profileFind all posts by mhSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
if you want to enable dbg to work with specified host you'd read
someone-s-got-to-go-first-t4.html
where I explained how to use debugger.hosts_allow and debugger.hosts_deny settings.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Hmmm, tried that...
Veteran

Joined: 16 Aug 2003
Posts: 101
Location: Montreal, Canada
Reply with quote
Hi Dmitri,

I've tried changing this a few times.

Firewall on both sides is currently totally disabled for these tests,

my php.ini reads:

debugger.enabled = true
debugger.profiler_enabled = true
debugger.hosts_allow = xx.xxx.xx.xx

and I've restarted Apache. I still get that the connection to my host is not allowed (and it lists the same IP I gave in the config).

I really, really want to get going! So far, phpED seems to be the way to go over other IDEs I'm evaluating, but I can't purchase until I fix this problem!

Thanks,

Martin
View user's profileFind all posts by mhSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
please make sure you are correcting the same php.ini as listed in the phpinfo() topmost header. Also make sure that extension=dbg.so-x.x.x is somewhere above the [debugger] section. Then make sure that there is only one debugger.hosts_allow setting in the file.
If you made sure about everything listed above and did not find any wrong stuff please send me all phpinfo() results, php.ini and screenshot or text copy of the message given on the client side.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Support call - private info
Veteran

Joined: 16 Aug 2003
Posts: 101
Location: Montreal, Canada
Reply with quote
Hi Dmitri,

I'll open a support call with the requested info. All of what you asked to check seemed set properly.

Thanks,

Martin
View user's profileFind all posts by mhSend private message
Solution
Veteran

Joined: 16 Aug 2003
Posts: 101
Location: Montreal, Canada
Reply with quote
Since I have not found any info pertaining to this, I thought I'd pass this along for anyone who might encounter this problem.

With the current eval distribution of phpED (3.2.1) and DBG 3.14.9, I had to add "dbg:all" in /etc/hosts.allow on RedHat 7.3.

Otherwise, the debugger would not allow any connection to any IP address on the outside.

Thanks to Dmitri and NuSphere support for their help.

Martin
View user's profileFind all posts by mhSend private message
dbg 2.14.9 - connection to client not allowed
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic