NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Can't get the debugger to work on local machine!


Joined: 24 May 2004
Posts: 13
Reply with quote
I'm just about to abandon this tool for something I can get to work. Crying or Very sad

I'm setting up my local WinXP Pro machine as a dev machine for php. Here's what I've got.

WinXP Pro
Apache 1.3.27 installed as module
PHP 4.3.6
PHPEd 3.3.1 eval
DBG extension 2.16.7
Localmachine IP 192.168.2.99 (static)

When I start a script in debugger mode, I still get the "Failed to start debugger session (timeout)". I've check all that I can. I even went as far as to reinstall everything PHP, PHPEd, DBG. But, I nothing works.

I've done followed all the instructions I could find for installation and troubleshooting per the sticky posts. I tried telnetting to the listener per the directions in this post tip-troubleshooting-debugger-communications-t579.html#2264 I'm able to make a connection to the listener this way, even though it reports that my telnet session is the "wrong client".

Here's my php.ini [debugger] section...

[debugger]
debugger.enabled=on
debugger.profiler_enabled=on
debugger.hosts_allow= 192.168.2.99 127.0.0.1
debugger.ports=7869, 10000/16

I don't know what else to do. I've lost days working on this issue and all I have is a php editor, no debugger, and growing frustration.

What else can I try?

Jimbo
View user's profileFind all posts by jimbonusphereSend private message
Follow up


Joined: 24 May 2004
Posts: 13
Reply with quote
Ok. I believe on onto the problem.

I'm trying to run a script on a sub-domain folder that I've copied down from the webhost server. I've got the URL and root directories for the project mapped to this sub-domain folder on my local Apache server (as if it were the root). However, it's not the same directory as the Apache document root. It's a subdirectory of the Apache document root.

I think that the debugger is not finding the file and is timing out. I say this because I can start the debugger ona script located in the *Apache* document root and it works. The message appears like a debugger problem, but is most likely a mapping issue.

All the mapping options for the project are a bit confusing. I'll take a look at them again tomorrow then I'm a bit more rested.

JImbo
View user's profileFind all posts by jimbonusphereSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7904
Reply with quote
debugger should work without any problem regardless the script is located in a document root subfolder or in document root itself.

Please let me know what your project settings are and where the files are physically located.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Solved, but yet another problem


Joined: 24 May 2004
Posts: 13
Reply with quote
Ok. The issue was my mapping for the project. I changed the mapping and I'm now able to run the debugger.

But...

I now this error message when debugging a script:

"Failed to Map Remote File "c:\foxserv\www\mamabo\index.php" to any local file"

I don't understand why I'm getting this error. I'll do a bit more checking on the forums.

Here's my setup on my WinXP box...

Apache Root:
c:\FoxServ\www

PHPEd project folder:
c:\Program Files\nusphere\phped\Projects\MAMBO
(all the files and sub directories are contained in this folder)

Here are some screen shots so you can see the rest of thet setup




What's the problem?

Jimbo
View user's profileFind all posts by jimbonusphereSend private message
Problem Solved


Joined: 24 May 2004
Posts: 13
Reply with quote
I thought I posted a response to my own problem. But I don't see it. So if you see this post somewhere else in the forum, please forgive.

My experience, and solution to this problem, may help someone else new to PHPEd and DBG.

Once I got the project mapping straightened out, I was able to debug, except for getting the "Failed to Map Remote File "c:\foxserv\www\mamabo\index.php" to any local file" error when starting the script. Here's what happened.

I originally had the Project Root directory mapped the same as the Remote Root Directory. But, I was in the habit of FTPing files to the remote server. That's because when I first started using PHPEd, I mapped remotely to my webhost's server. When I moved everything locally to my WinXP machine, I continued to FTP files to the "remote" server (now localhost). Since I was FTPing the same file I was editing (becuase project root = remote root), I was getting wierd errors, and I would even loose the contents of files. So, to correct this problem I separated source files from server files into separate directories, and then changed the project mappings as such.

While this fixed my FTP problem, it created the problem with debugger not being able map the remote file (in the remote root) with a local file (now in a separated directory locally).

The fix was simply to put things back the way they were and map the root directory to the remote root directory again. Now when I save edited files, I just save. I don't FTP. Everything works fine.

Thanks for the assitance.

Jimbo
View user's profileFind all posts by jimbonusphereSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7904
Reply with quote
yeah, publishing files to the same directory on the same machine is a good habit, indeed Smile
Why don't you work without publishing at all ?
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Can't get the debugger to work on local machine!
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic