NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
[resolved] Run/Debugging encoded project


Joined: 16 Jul 2009
Posts: 15
Reply with quote
I have an encoded project that doesn't run the same like the original source. E.g.:
Code:

try {
  if(!$var)
    throw new IException("my message");
}
catch(IException $e) {
  echo $e->getMessage();
}

The not encoded script print's out the message. The encoded script says: "Fatal: calling method on non-object".

The other thing is, that remote debugging doesn't work very well:
Code:

function($container) {
 
  $var = $container["name"];

}

The variable $container is treated as null in debugger. After that line $var is also null. On a another place array-vars are handeld correctly.

PHP 5.2.12
Encoder-Version: latest with LicenceManager and basic obfuscation.

Are there any coding standards that I have to use to get this thing work properly?
Ty.
View user's profileFind all posts by vvbSend private message


Joined: 16 Jul 2009
Posts: 15
Reply with quote
It seems to be an obfuscation problem. Without obfuscation the debugger seems to work correctly and the "fatal: calling method on non-object" error doesn't appear.

Is this a known limitation or a bug?
View user's profileFind all posts by vvbSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7857
Reply with quote
it was a bug, which was fixed quite a lot time ago
(sorry I didn't notice this post before)

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
[resolved] Run/Debugging encoded project
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic