NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
PhpED Code Completion Stops working

Joined: 03 Nov 2010
Posts: 3
Reply with quote
I've used phped for well over a year with no problem. Then one day it just sort of stalled and a message came up saying "Code completion parser has been stopped due to an internal error. You may want to restart the IDE to get Code Insight working.

Restarting doesn't help. I'm not exactly sure what i was doing at the time, but my best guess is that I had renamed some files on disk that I might have had open in phped. Nothing happened directly after that, but its my best guess of the cause. I found that if i reverted (using SVN) back to older project files, the code parser would start working again. That worked for awhile as a work around, but the problem seemed to get worse. Eventually, and reluctantly (because phped was working so great before) I upgraded to phped 5.9. The problem was still there, and by still there i mean i'd start phped, then about a minute later it would throw the Code completion parser error after spinning the CPU up to 100% for about 4 minutes.

I've tried removing the files that i may have renamed, nuking all the projects and starting new ones. Nothing seems to work and i'm getting frustrated. I have over 600 php files in my project I NEED the code navigator and code completion to work.

I have a feeling there is some file in my project that caused the code parser in phped to loose it's mind and go into an infinite loop.

I'm running WinXP SP3, SVN, Apache 22, php 5.2.8 on windows.

If anyone has run into anything similar please let me know.

View user's profileFind all posts by tsquaredSend private message
PhpED Code Completion Stops working
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

 Reply to topic