NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Install correct version?


Joined: 24 Apr 2004
Posts: 6
Reply with quote
Hi,

after installing the dbg, my phpmyadmin does not start anymore.
I used the dbg.so-4.3.2 for my php 4.3.5, because I could'nt find
the correct one. Also, I have already the ZEND-Engine running.

Where do I get the correct version of the debugger?

Thanks

Martin
View user's profileFind all posts by fmschraderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
dbg.so-4.3.2 should work... but php-4.3.5 itself is not really good. Please install 4.3.4 or 4.3.6 then proceed with instructions on how to install dbg module if other Zend extensions are loaded:
how-to-run-dbg-with-winenabler-t648.html
certainly, zend_extension_ts="<full_path_to_php_dbg>\php_dbg.dll-4.3.4" should be substituted to
zend_extension="<full_path_to_dbg>/dbg.so-4.3.2"
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Apr 2004
Posts: 6
Reply with quote
Thanks,

it looks like it worked.

I get now:
This program makes use of the Zend Scripting Language Engine:
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies with DBG v2.11.23, (C) 2000,2001,2002,2003, by Dmitri Dmitrienko with Zend Extension Manager v1.0.1, Copyright (c) 2003, by Zend Technologies with Zend Optimizer v2.5.1, Copyright (c) 1998-2004, by Zend Technologies


Now I will start playing round. Thanks again.

Martin
View user's profileFind all posts by fmschraderSend private message


Joined: 24 Apr 2004
Posts: 6
Reply with quote
Ok, thank was too fast...

A little question, how do I start debugging scripts on my server now?
Do I have to have the PHPED installed? Or is there a way to
use only the debugging itself?

Ciao

Martin
View user's profileFind all posts by fmschraderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
dbg 2.11.23 (freeware version) is intened for 3rd party IDEs capable to work with dbg listener (aka dbg client).
Regarding PHPED, it comes with it own version of debugger (currently 2.16.7) and you have to install it if you want to work with PHPED.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Apr 2004
Posts: 6
Reply with quote
Aha,

it is version 2.11.23, the freeware. So what do I need to use it?

Ciao

Martin
View user's profileFind all posts by fmschraderSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
As I told you you have to find and install 3rd party IDE that is capable to work with it. I _can_ _not_ advertize or suggest them there. Sorry for that.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 24 Apr 2004
Posts: 6
Reply with quote
I understand.

Thanks anyway Dimitrie.

Ciao

Martin
View user's profileFind all posts by fmschraderSend private message
Install correct version?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic