NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
DBG install problem in RH9.0


Joined: 19 Aug 2003
Posts: 2
Reply with quote
Hi
I have installed Apache 2.0.47, php 4.3.2 in RH linux 9.0.
I downloaded the relevant .so and made the changes in php.ini. When I run phpinfo(),
the dbg section shows up and I also get this funny message
PHP DBG ZExtension is not activated, yet.
Check configuration parameters in the php.ini file.

I have added the [Debugger] section in the correct place with the following lines
debugger.enabled = true
debugger.profiler_enabled= true
debugger.JIT_host = clienthost
debugger.JIT_port = 7869
debugger.JIT_level=3
debugger.hosts_allow=localhost,127.0.0.1,192.168.2.*
debugger.ports=10000/16,7869

What's wrong? Further, I am guessing that firing php ed would automatically fire up the listener. Once it is working, is it possible to direct the profiler o/p to a file?

Crying or Very sad
View user's profileFind all posts by kgsubraSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
It may be caused by conflict with some other modules.
Please try to remove one-by-one everything that's loaded with zend_extension=...

As a possible workaround you can try to add
zend_extension=/pathtodbgso/dbg.so-x.x.x
on the topmost line of php.ini
Line with extension=dbg.so should remain be.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Problem Solved


Joined: 19 Aug 2003
Posts: 2
Reply with quote
Hi There,
Removing the lines related to Zend did the trick. Now phpinfo() shows all the correct values.

Now I am having problem with both the local and remote debugging.
In local debugging using the external web server and php I can step through code, breakpoints etc. How do I see the performance window where I can see the timings for different function calls etc.

In the remote debugging, I start phped, and launch the browser with DBGSESSID and clienthost. Nothing happens within php ed. I expected to see the appropriate php files popup.

Now what?

thanks
View user's profileFind all posts by kgsubraSend private message
DBG install problem in RH9.0
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic