NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Opening A File - Wants Me To Save?


Joined: 05 May 2004
Posts: 3
Reply with quote
Whenver I open a file just to view the contents, The IDE wants me to save that same file again even though I didn't do anything to the file.

I know its not a big deal to 'click' no or yes. but it does get annoying.

I disabled Code Completion but that still doesn't work.

It happens As Soon As Opening The File. Didn't even click inside the editor and the little '*' comes up beside the filename. I'm hoping that this is a bug and not a feature?

I'm using 3.3 Trial.

Any ideas on disabling this?

Thanks
View user's profileFind all posts by bmadiganSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Actually, it _never_ ask you to save file if it was not modified.
File can be implicitly modified if for example you checked "Optimal Fill" in the editor options.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 05 May 2004
Posts: 3
Reply with quote
Optimal Fill is unchecked.

I just don't understand that if I wanted to highlight a function in (for example: User.php), all I do is drag my mouse and highlight and Copy (Not Cut) the function, how does that modify the file User.php?

I've Never seen that in any other editor before.
View user's profileFind all posts by bmadiganSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7901
Reply with quote
Well, if you have either "Optimal Fill" checked or "Keep trailing blanks" unchecked the editor may modify the file for you. For example, Optimal Fill replaces spaces left to the first non-space character to minimal number of tabs and spaces. Similarly, Keep trailing blanks when unchecked removes all spaces right to the last non-space character.
BTW, it's not a phped innovation, raither common features available in many other editors.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 05 May 2004
Posts: 3
Reply with quote
I did have the 'Keep Trailing Blanks' option unchecked and that was it. It was 'automatically' modifying the file. I checked it, and and it works great now! It was annoying.

Quote:
BTW, it's not a phped innovation, raither common features available in many other editors.


Rolling Eyes

I agree. I was just looking for an alternative in the options as to why that was happening.

Thanks!
View user's profileFind all posts by bmadiganSend private message
Opening A File - Wants Me To Save?
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic