NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
<script> remove colors


Joined: 01 Aug 2003
Posts: 13
Reply with quote
Hello

when having <script> in a .php file everything below it is greyed out.

Like

Code:

<html>
<script>
<?php
/* no php syntax color */
?>
Still none...


Any suggestions? (PHPEd 3.3 Build 3332eval)
View user's profileFind all posts by cyppeSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Quote:
Any suggestions?


Please take a look at the screenshot:



as far as I see, threre is no problem.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 01 Aug 2003
Posts: 13
Reply with quote
Look here:



As you see, when I remove "<" from the "<script>" tag it works.
View user's profileFind all posts by cyppeSend private message


Joined: 01 Aug 2003
Posts: 13
Reply with quote
Noticed a funny thing by accident now,
it happend becuse I had the <script> tag after </head>.

-- edit

But if I move </head> below it it works as I said, but not if I move it below the php block.

View user's profileFind all posts by cyppeSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
yep, some discrepancy is here....
will be fixed in 3.3 service pack #1.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
also w/ <style>


Joined: 06 Oct 2003
Posts: 13
Reply with quote
this looks familiar except the problem i had was with a <style> section. if i put a <style>...</style> section in my html document, it would disable all syntax highlighting after that section. also, if you typed an html tag after that section it would close it with </style> instead of the proper closing tag.

for example, if you typed:
<p>
phpED would close the tag and you would have this:
<p></style>

i'll make some screenshots if that would help. is this already an identified bug?
View user's profileFind all posts by nebySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
Quote:
for example, if you typed:
<p>


if you typed <p> inside <style>, it's a nonsense from CSS point of view Smile
and sequence like <style>..._anything_... should always be closed with </style>, isn't it ?
I see no problem so far.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 06 Oct 2003
Posts: 13
Reply with quote
that's true, but i was referring to html tags typed after the style section, not inside it. sorry if that wasn't apparent. for example:
Code:

<html>
<head>
    <style>
    body { font-family: Arial, Helvetica, sans-serif; }
    .stuff { color: #112233; }
    </style>
</head>
<body>
<?php
// can't get syntax highlighting when placing the cursor inside here
?>
<p>|
</body>
</html>

where I placed the vertical bar, just after that opening <p> tag... what happens is, when phpED auto-completes that tag it does so with a </style> tag.[/code]
View user's profileFind all posts by nebySend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7897
Reply with quote
I just tested in PHPED HOTFIX1 (build 3338) and everything went fine.
It inserted </p> and showed php properly highlighted:


Check menu View->HTML (F12)
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 06 Oct 2003
Posts: 13
Reply with quote
cool, thanks for following up. i suspect this was a bug in 3.2 related to the auto-highlight switching feature. although that wouldn't explain the tag-completion part... whatever.
View user's profileFind all posts by nebySend private message
<script> remove colors
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic