NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
dbg-cli list command not showing source or anything


Joined: 03 Apr 2004
Posts: 2
Reply with quote
I am using dbg-cli and, using DebugBreak() in the PHP script, can sporatically get the "run" to work in dbg-cli. Unfortunately, I am unable to see what line is being debugged. I am unable to get "list" to work at all, even if I use "file" to set the source.

Here's a sample session:
dbg>run
Starting program: `/var/www/etc/phpwiki/index.php4'
/etc/phpwiki/index.php4:828 <debugbreak()>
dbg>next
/etc/phpwiki/index.php4:831 </etc/phpwiki/index.php4::main()>
dbg>next
/etc/phpwiki/index.php4:836 </etc/phpwiki/index.s="r::main()>
dbg>list
dbg>file /var/www/etc/phpwiki/index.php4
Reading symbols from /var/www/etc/phpwiki/index.php4...done.
dbg>list
dbg>

Any help is appreciated.
View user's profileFind all posts by robertbSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7891
Reply with quote
it's a known limitation. "List" command is not supported.
When DDD debugger works though dbg-cli it goes through special code that brings sources from local disk according to mapping settings.
View user's profileFind all posts by dmitriSend private messageVisit poster's website
emacs might work, then?


Joined: 03 Apr 2004
Posts: 2
Reply with quote
Quote:
When DDD debugger works though dbg-cli it goes through special code that brings sources from local disk according to mapping settings.

I assume this means that GNU Emacs may work since it interprets gdb output. I'll give it a go.
View user's profileFind all posts by robertbSend private message
dbg-cli list command not showing source or anything
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic