NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Apache + DBG only loading once, failing after reboot


Joined: 04 Apr 2004
Posts: 1
Reply with quote
Hello!

I use the current disti of SuSE 9.0 with:
- Apache 1.3.28
- PHP ver 4.3.3
- DBG php debugger, version 2.16.3 (for PHP 4.3.3-i386 as bundled with PhpED)

My php.ini:

extension_dir = "/usr/share/extensions/dir1"

{... something here ...}

[extension section]
extension=dbg.so

[debugger]
debugger.enabled = true
debugger.profiler_enabled = true
debugger.JIT_host = clienthost
debugger.JIT_port = 7869


The file "dgb.so" is located at "/usr/share/extensions/dir1" - and Apache starts fine, phpinfo() shows that the DBG module is loaded.

But the problem is:
After a reboot Apache does NOT start fine, though configured to start at runlevel 2,3,5.
(Also when I try to start Apache manually, it does not start)

I found out a workaround that helps:
After the reboot, I have to create a new directory, e.g. extension_dir = "/usr/share/extensions/dir2", then copy "dbg.so" to the new location, modify the "php.ini" to use the new directory as extension source.
Then everything works fine, BUT AGAIN ONLY ONCE.

After a reboot I have to do same again with a new directory, and so on.
Of course, this workaround is a bad solution for daily work on my development server.

Any hints / suggestions?

Thanks in advance.

_________________
Regards,
Andreas.
View user's profileFind all posts by mediasSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7881
Reply with quote
set apache log level to debug and check its log files after reboot.
Cool
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Apache + DBG only loading once, failing after reboot
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic