NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Can not make it to debug - Protocol error


Joined: 16 Sep 2009
Posts: 1
Reply with quote
I am having problems at debugging

I use denver as virtual server

My environment is that my browser is IE 7 running under Windows XP

I have followed all of the instructions as far as I can:

Here is the output of dbg-wizard.php

PHP Version: 5.2.4
Web Server: Apache/2.2.4 (Win32) mod_ssl/2.2.4 OpenSSL/0.9.8d PHP/5.2.4
Server Name: biplan
Platform: WINNT/x86
Your Client IP Address: 127.0.0.1
Your Server IP Address: 127.0.0.1
Port: 80
Your Web Server is on the same machine with PhpED
Path to website files: Z:\home\biplan\www\
Document Root is: Z:\home\biplan\www\
Your PHP.INI file is: Z:\usr\local\php5\php.ini
PHP extensions directory is: \usr\local\php5\ext
DBG (PHP DEBUGGER) Version 3.1.11 is INSTALLED
Installed DBG module is of an older version than currently available from NuSphere

I have added the following text to php.ini on the webserver -
extension=php_dbg.dll-5.2.x


[debugger]
debugger.enabled=On
debugger.profiler_enabled=On

debugger.hosts_allow=127.0.0.1
debugger.hosts_deny=ALL
debugger.ports=7869, 10000/16


I brought up a php page in IE that simply contained

<?php
phpinfo();
?>

and then called address http://biplan/delme.php?DBGSESSID=1&PHPEdHidden=72796 on the phpED IE adress bar - and get the following error:

DBG 3.1.11

Failed to run DBG session


Reason: protocol error ()
Not sure what it means? Visit http://www.nusphere.com/dbg/ for troubleshooting.


Debugger request: "1&PHPEdHidden=72796"
Request found in: "query_string"
Target PHP version: "5.2.0"
Server API: "Apache 2.0 Handler"
Extensions API: "220060519"
Modules API: "20060613"
PHP API: "20041225"

Any ideas what I'm doing wrong ?
View user's profileFind all posts by luryeSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
You said nothing about version of IDE.
Probably you took debugger module from an old version of the IDE.
Check the version of the debugger that was shipped with IDE.

_________________
The PHP IDE team
View user's profileFind all posts by dmitriSend private messageVisit poster's website
Can not make it to debug - Protocol error
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic