NuSphere Forums Forum Index
NuSphere Forums
Reply to topic
Debug under phpED 3.2evl... got error.


Joined: 24 Jul 2003
Posts: 1
Reply with quote
"Wrong version (2.11) of debugger module detected. Debugger module version of 2.14 is needed to start debug seesion."

I am using FreeBSD/Apache, where can I find dbg 2.14? or, Is there any other useful debugger?

Thanks in advance.
View user's profileFind all posts by artantSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
Modules of DBG 2.14.9 for FreeBSD 4.8 platform are in the debugger subdirectory. See there four tar.gz archives. Two for linux and two fro FreeBSD, each pair consists of i386 and i686 (optimized) binaries.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 11 Aug 2003
Posts: 2
Reply with quote
What about DBG 2.14.9 for win 2003 server? I have the same error.

If in debugger setup choos in IDE COM class " PHPEd IDE ver 3.2" debugger not connect.
View user's profileFind all posts by YorikSend private message
Site Admin

Joined: 13 Jul 2003
Posts: 7861
Reply with quote
Leave DbgListener alone. It's fully and automatically configured by IDE when you run it. The only setting that might be interesting is Code Page. It's what used for translating texts passed by debugger protocol.

If you ever encounter a particular problem with setting IDE or debugger up please specify the following:
a) what did you do in the IDE (e.g. what buttons were clicked, what settings were set for IDE and for the project).
b) what log entries were found in the apache access log and apache error log
c) what log entries were found the dbg listener.
d) what log entries were found in the IDE.
e) what actual error message (if any) was given.
View user's profileFind all posts by dmitriSend private messageVisit poster's website


Joined: 11 Aug 2003
Posts: 2
Reply with quote
Oups! My mistake! It`s about PHP Expert Editor 3.0. Sorry.
View user's profileFind all posts by YorikSend private message


Joined: 11 Aug 2003
Posts: 11
Reply with quote
Hi!!!
I've tried the debugger but I get the same message as the other users.
My OS is win2000 and I dont know how get the debugger version 2.14.
I have tried to search the logs that you said but I havent found any.
Alvaro
View user's profileFind all posts by inforalvSend private message


Joined: 11 Aug 2003
Posts: 11
Reply with quote
I have forgotten it:
I have PHPed 3.2 and PHP 4.3.2
View user's profileFind all posts by inforalvSend private message


Joined: 11 Aug 2003
Posts: 11
Reply with quote
I have solved it myself!!!
The problem is that I´m using my own version of PHP and the library php_dbg.dll belonged to another debugger.
I only have had to copy the file php_dbg.dll that belong to debugger of PHPed (its located in %installation_directory%nusphere\phpED\php\extensions) in my directory extensions of PHP.
Alvaro
View user's profileFind all posts by inforalvSend private message
Debug under phpED 3.2evl... got error.
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
All times are GMT - 5 Hours  
Page 1 of 1  

  
  
 Reply to topic